npm। पैकेज प्रबंधक को Node.js. के साथ भेज दिया गया है इसका उपयोग कॉमनजस और ईसीएमएस्क्रिप्ट मॉड्यूल, jQuery प्लगइन्स, पुन: प्रयोज्य जावास्क्रिप्ट कोड (पुस्तकालयों), जावास्क्रिप्ट-आधारित सीएलआई कार्यक्रमों और अन्य को स्थापित करने और प्रकाशित करने के लिए किया जा सकता है।

के बारे में अधिक npm...

मैंने npm एक्सप्रेस और सर्व-फ्लेविकॉन स्थापित किया है, वे npm ls और npm ls --global में मौजूद हैं लेकिन मुझे अभी भी Error: Most middleware (like favicon) is no longer bundled with Express and must be installed separately मिल रहा है const https = require('https'); const fs = require('fs'); const exp....
21 नवम्बर 2021, 10:50
मैं आमतौर पर विंडोज़ पर काम करता हूं और मैं अपने मैक पर सभी संभावित तरीकों से वीयू को स्थापित करने की कोशिश कर रहा हूं, लेकिन जब मैं टाइप Vue या vue --version पर जांच करता हूं, तो मुझे व्यवस्थित रूप से zsh: command not found: vue प्राप्त होता है। मैं कोशिश कर रहा सभी आदेश: npm install -g @vue/cli@la....
21 नवम्बर 2021, 02:29
मैं MacBook Air M1 से अपना एक डॉकर कार्य प्रोजेक्ट चलाने का प्रयास कर रहा हूं और docker-compose up निष्पादित करते समय मुझे निम्न त्रुटि मिल रही है। जाहिरा तौर पर यह अजगर स्थापना नहीं ढूंढ सकता, भले ही मैं टर्मिनल से python --version और python3 --version दोनों कर सकता हूं। मैं डॉकर के लिए अपेक्षाकृ....
20 नवम्बर 2021, 18:55
कृपया उदाहरण रेपो देखें https://github.com/inspiraller/webpack-and-microbundle माइक्रोबंडल कोड mymicrobundle/src/index.js import React from 'react' const MyMicroBundle = ({session}) => { return ( <div>Session = {session}</div> ) } export default MyMicroBundle microbundle/package.json - ....
19 नवम्बर 2021, 21:10
मैं अपनी परियोजना को स्थापित करने की कोशिश कर रहा हूं ताकि मेरे पास एक सामान्य पुस्तकालय हो सके जिसका उपयोग दो अलग-अलग वीप-ऐप्स द्वारा किया जाता है। सभी ऐप रिएक्ट का उपयोग करते हैं और मैं पहले वेब-ऐप के एक हिस्से को तोड़ने पर काम कर रहा हूं, जिसे मैंने अपनी लाइब्रेरी, कॉमन लाइब्रेरी में काम किया है....
18 नवम्बर 2021, 02:57
मैं lerna ls के समान एक NPM कमांड ढूंढ रहा हूं जो सभी कार्यस्थानों का प्रिंट आउट ले। उदाहरण के लिए, मान लें कि मेरे पास एक packages उप-निर्देशिका में package1 और package2 हैं और मेरा package.json इस तरह दिखता है: "workspaces": [ "./packages/*" ] मैं एनपीएम 7 कार्यस्थानों की एक सूची प्राप्त करना चा....
15 नवम्बर 2021, 23:47
npm install @uiw/react-monacoeditor --save बनाम npm i @uiw/react-monacoeditor निम्नलिखित npm इंस्टाल स्टेटमेंट में क्या अंतर है जब --save फ्लैग का उपयोग करें?....
15 नवम्बर 2021, 23:36
मैं मोबाइल नंबर प्रदर्शित करने के लिए नियंत्रण बनाने के लिए intl-tel-input का उपयोग कर रहा हूं। क्योंकि झंडे वास्तव में छोटे हैं, मुझे उन्हें बड़ा करने की आवश्यकता है। जैसा कि वे यहां वर्णन कर रहे हैं: https://codepen.io/jackocnr/full/ONXWgQ ऐसा करने के लिए मुझे grunt img और grunt css दौड़ना चाहिए।....
15 नवम्बर 2021, 20:22
मैं प्रतिक्रिया देशी ऐप चलाने की कोशिश कर रहा हूँ। जब मैं npx react-native start सर्वर प्रारंभ करता हूं, तो प्रतिक्रिया लोगो प्रदर्शित करता है और त्रुटि के साथ क्रैश होता है npm[11708]: c:\ws\src\util-inl.h:369: Assertion `!(n > 0) || (ret != nullptr)' failed. मैं विंडोज़ 10 का उपयोग कर रहा हूँ।....
13 नवम्बर 2021, 20:49
PS C:..project\src\features> npm run storybook > sfe-template-20@0.1.0 storybook > start-storybook -p 6006 'start-storybook' is not recognized as an internal or external command, operable program or batch file. स्थापित स्टोरीबुक लेकिन इसे चलाने के लिए प्रतीत नहीं हो रहा है। मैंने npm इंस्टॉल करन....
13 नवम्बर 2021, 17:02
मैंने एज़ूर फ़ंक्शन ऐप - ऐप सर्विस एडिटर पर एनपीएम के मेरे आवश्यक संस्करण को स्थापित करने के लिए निम्न आदेशों का प्रयास किया है लेकिन काम नहीं किया है। पुन: उत्पन्न करने के लिए: मैंने विंडोज़ में स्थानीय रूप से विजुअल स्टूडियो में फंक्शन ऐप (.NET) बनाया है और एज़्योर फंक्शन ऐप (स्टैक - .NET 3.1 एलटी....
13 नवम्बर 2021, 04:04
मुझे लूम-ट्रफल-प्रदाता स्थापित करने में कोई परेशानी नहीं हो रही है। नोड = v14.18.1 npm = 6.14.15 लिनक्स उबंटू 20.04 मैं स्थानीय या विश्व स्तर पर स्थापित करने का प्रयास कर सकता हूं। दोनों नीचे त्रुटि के साथ विफल: ~$ npm install -g loom-truffle-provider make: Leaving directory '/home/joe/.npm-global....
13 नवम्बर 2021, 03:24
मेरी *.ts फ़ाइल को NPM में कैसे प्रकाशित करें जिसमें केवल प्रकार और इंटरफ़ेस परिभाषा हो? कोई निर्यातित जावास्क्रिप्ट फ़ंक्शन, ऑब्जेक्ट, आदि नहीं है। क्या मुझे इसे मिटा देना चाहिए? "main": "index.js", -या- "main": "dist/types.ts", से बदलें क्या मुझे *.ts को *.d.ts में संकलित करना चाहिए? प्रकार.जेएस....
12 नवम्बर 2021, 16:41
जब मैं इस आदेश का उपयोग करता हूं तो मुझे एक समस्या होती है: ng add @ngrx/store@latest मुझे यह त्रुटि मिलती है: npm ERR! code ERESOLVE npm ERR! ERESOLVE unable to resolve dependency tree npm ERR! npm ERR! While resolving: ngstore-app@0.0.0 npm ERR! Found: @angular/core@13.0.0 npm ERR! node_modules/@....
9 नवम्बर 2021, 23:18
मैं package-lock.json में स्थानीय निर्भरता के लिए अखंडता जांच को कैसे अक्षम कर सकता हूं? मेरे भंडार में, मेरे पास आधार पुस्तकालय के साथ-साथ दो कोणीय ऐप्स हैं, दोनों मेरे आधार पुस्तकालय को निर्भरता के रूप में उपयोग करते हैं। दुर्भाग्य से, आधार पुस्तकालय की अखंडता sha512 प्रत्येक बिल्ड के साथ अलग ....
8 नवम्बर 2021, 20:00
मेरे पास एक कोणीय ऐप है। package.json में मैंने सभी कोणीय पैकेजों के लिए संस्करण 12.2.9 परिभाषित किया है जैसे: "@angular/animations": "^12.2.9", "@angular/cdk": "^12.2.9", "@angular/common": "^12.2.9", "@angular/compiler": "^12.2.9", "@angular/core": "^12.2.9", ... मैंने node_modules फोल्डर और 'pa....
8 नवम्बर 2021, 10:26
मैं अपने react ऐप पर react-twitter-embed इंस्टॉल करने का प्रयास कर रहा हूं। मैंने अपने node_modules फ़ोल्डर को हटाने और पुनर्स्थापित करने और अपना npm कैश साफ़ करने का प्रयास किया है। मैंने अपने node और npm को भी नवीनतम संस्करण में अपग्रेड करने का प्रयास किया है। मुझे जो त्रुटि मिल रही है वह यहां ....
5 नवम्बर 2021, 21:42
अनजाने में मेरी package.json फ़ाइल में "-" नामक पैकेज जोड़ दिया गया है। मेरा मानना ​​है कि यह पैकेज है: https://www.npmjs.com/package/- मैं ncu (https://www.npmjs.com/package का उपयोग कर रहा था /npm-check-updates) कुछ पैकेजों को अपग्रेड करने के लिए, फिर मैंने देखा कि "निर्भरता" में एक नई लाइन जोड....
5 नवम्बर 2021, 20:42
जब मैं अपने प्रतिक्रिया ऐप में नोड-एसएएस जोड़ता हूं तो मुझे यह त्रुटि होती है, मैं नेटलिफाई में ऐप को तैनात नहीं कर सकता मैं सीआई = रन बिल्ड जैसे सभी बिल्ड सीएमडी का उपयोग करने की कोशिश करता हूं, कृपया नीचे परिणाम देखें, ऐप तैनात है netlify में जब मैं अपने ऐप से नोड एसएएस हटाता हूं और काम करता है ....
5 नवम्बर 2021, 16:35
मेरे पास नोड/एनपीएम पर आधारित एक प्रोजेक्ट है और कमिटलिंट, हस्की और सिमेंटिक-रिलीज़ का उपयोग करें। जब भी मैं संरक्षित main शाखा को धक्का देता हूं तो मैं एक नई रिलीज बनाना चाहता हूं। गीथूब में मैंने निम्नलिखित वर्कफ़्लो जोड़ा: name: Release on push on main on: push: branches: - main jo....
4 नवम्बर 2021, 18:31
मैं परिणाम एनपीएम ऑडिट संलग्न कर रहा हूं। समस्या को अपने दम पर हल करने के प्रयास कहीं नहीं ले गए हैं। अगर कोई समस्या का सार समझा सकता है तो मैं आभारी रहूंगा। इसे लंबे समय तक ठीक नहीं कर सकता। शायद समाधान सरल और तार्किक है, लेकिन दुर्भाग्य से यह मेरे लिए स्पष्ट नहीं है। High Reg....
2 नवम्बर 2021, 23:37
अच्छी तरह से मेरी समस्या यह है कि जब मैं अपने जेस्ट टेस्ट को चलाने के लिए अपने स्क्रिप्ट कमांड को package.json जैसे "स्टार्ट" से "टेस्ट" में स्विच करना चाहता हूं, जो इसके कमांड की तरह है: "scripts": { "start": "nodemon express/***", "serve": "node express/***", "dev": "node expres....
2 नवम्बर 2021, 20:54
मैं नोड के संस्करण 14.17.0 को चलाने के लिए nvm के साथ काम कर रहा हूं: nvm current v14.17.0 मैं package.json और package-lock.json फाइलों वाले प्रोजेक्ट के फोल्डर के अंदर हूं। मुझे परियोजना की निर्भरता स्थापित करने की आवश्यकता है इसलिए मैं nvm install चलाने की कोशिश करता हूं, लेकिन मुझे जल्द ही पता च....
1 नवम्बर 2021, 19:06
सब! मैं क्या गलत कर रहा हूँ या मैं क्या खो रहा हूँ? मैं Win10 सर्वर पर ioBroker स्थापित करने का प्रयास करता हूं। मैं नीचे दिए गए PowerShell सत्र से एक (एक प्रकार का) लॉग जोड़ूंगा। अतिरिक्त: एक विजुअल स्टूडियो 2019 समुदाय और एक विजुअल स्टूडियो कोड स्थापित है। मुझे विंडोज़ बिल्ड टूल्स (अब तक वीबी.न....
31 अक्टूबर 2021, 19:00
package.json सबसे पहले मैंने यह किया, { "name": "crypto-local-storage", "version": "0.0.1", "peerDependencies": { "@angular/common": "^12.2.0", "@angular/core": "^12.2.0", "crypto-js": "^3.1.8", "secure-web-storage": "^1.0.2" }, "dependencies": { "tslib": "^2.3.0" }, ....
30 अक्टूबर 2021, 15:55