तो मेरे पास वह आउटपुट है जब मैं "py get-pip.py" या "python get-pip.py" टाइप करता हूं। यहां चित्र विवरण दर्ज करें

जब मैं "पायथन --वर्जन" टाइप करता हूं तो मेरे पास यह था। छवि विवरण यहां दर्ज करें

और जब मैं "py --version" टाइप करता हूं तो मेरे पास यह था। छवि विवरण यहां दर्ज करें

मैंने अजगर को फिर से स्थापित करने की कोशिश की, हटाने के बाद बचे हुए अजगर फ़ाइलों की खोज की, और कुछ भी मदद नहीं करता है।

0
Дмитрий Гуща 22 नवम्बर 2021, 17:28
Python 3.x में pip बंडल है, आपको get-pip.py चलाने की आवश्यकता नहीं है। यहाँ वास्तव में क्या मुद्दा है?
 – 
C.Nivs
22 नवम्बर 2021, 17:29
क्या होगा अगर आप python -m pip कोशिश करें
 – 
C.Nivs
22 नवम्बर 2021, 17:35
आउटपुट सिर्फ "पायथन" है
 – 
Дмитрий Гуща
22 नवम्बर 2021, 17:39

1 उत्तर

सबसे बढ़िया उत्तर

क्या आप विंडोज़ का उपयोग कर रहे हैं? मेरे अनुभव के आधार पर, पायथन को सीधे उनकी वेबसाइट https://www.python.org/downloads/ से डाउनलोड करने का प्रयास करें। और विंडोज़ स्टोर से नहीं।

0
cseegm 22 नवम्बर 2021, 17:37
वह सेटअप फ़ाइल सीधे वेबसाइट से डाउनलोड की गई थी, न कि विंडोज़ स्टोर से
 – 
Дмитрий Гуща
22 नवम्बर 2021, 17:39
हो सकता है कि आपके पास पहले से ही पाइप स्थापित हो। कमांड प्रॉम्प्ट में pip --version टाइप करने का प्रयास करें।
 – 
cseegm
22 नवम्बर 2021, 17:50
नहीं, आउटपुट है: "पाइप" आंतरिक या बाहरी कमांड, निष्पादन योग्य प्रोग्राम या बैच फ़ाइल नहीं है"
 – 
Дмитрий Гуща
22 नवम्बर 2021, 17:52
जब आपने अजगर को फिर से स्थापित किया, तो क्या आपने इंस्टॉलर में वैकल्पिक सुविधाओं के तहत बॉक्स को चेक किया था? यदि नहीं, तो आपको अपने पाइप के पथ को अपने पथ सिस्टम चर stackoverflow.com/a/23709194/17471835
 – 
cseegm
22 नवम्बर 2021, 18:04
1
मैंने "पीई-एम पीआईपी" टाइप करने की कोशिश की और यह काम करता है, मदद के लिए धन्यवाद!
 – 
Дмитрий Гуща
22 नवम्बर 2021, 18:15