मैं एडब्ल्यूएस के लिए नया हूं, डायनेमोडीबी से एस 3 में डेटा लोड करके एडब्ल्यूएस डेटा पाइपलाइन चलाने की कोशिश कर रहा हूं। लेकिन मुझे नीचे त्रुटि मिल रही है। कृपया सहायता कीजिए

@EmrClusterForBackup_2020-05-01T14:18:47 के कारण संसाधन बनाने में असमर्थ: इंस्टेंस प्रकार 'm3.xlarge' समर्थित नहीं है। (सेवा: AmazonElasticMapReduce; स्थिति कोड: 400; त्रुटि कोड: सत्यापन अपवाद; अनुरोध आईडी: 3bd57023-95e4-4d0a-a810-e7ba9cdc3712)

1
NikRED 1 मई 2020, 17:37
एम 3 इंस्टेंस प्रकार ईएमआर पर बहिष्कृत हैं, जो समस्या पैदा कर रहा हो सकता है। क्या आपने m4.xlarge या m5.xlarge का उपयोग करने का प्रयास किया है?
 – 
Mark B
1 मई 2020, 17:42

3 जवाब

सबसे बढ़िया उत्तर

नवीनतम पीढ़ी के उदाहरणों का उपयोग करना हमेशा अच्छा होता है। वे तकनीकी रूप से अधिक उन्नत हैं और कभी-कभी सस्ते भी।

तो पुरानी पीढ़ियों पर शुरू करने का कोई कारण नहीं है .. वे केवल उन लोगों के लिए हैं जिनके पास पहले से ही उन मशीनों पर बुनियादी ढांचा है .. इसलिए पिछड़ी संगतता प्रदान करने के लिए।

1
Deepak Singhal 1 मई 2020, 17:58
पिछली पीढ़ियों के समकक्ष चश्मे के लिए लगभग हमेशा सस्ता
 – 
jordanm
1 मई 2020, 17:54
सभी को धन्यवाद!!। यह अभी भी वही त्रुटि फेंक रहा है (m3.xlarge कह रहा है) इसे m4.xlarge में बदलने के बाद भी। परिभाषा के हिस्से के नीचे। { "नाम": "EmrClusterForBackup", "coreInstanceType": "m4.xlarge", "coreInstanceCount": "1", "masterInstanceType": "m4.xlarge", "releaseLabel": "emr-5.23.0", " id": "EmrClusterForBackup", "region": "#{myDDBRegion}", "type": "EmrCluster" },
 – 
NikRED
2 मई 2020, 05:06
कृपया m5 की कोशिश करें .. वह नवीनतम पीढ़ी है .. अगर फिर भी यह काम नहीं करता है; मैं अपने अंत में समस्या को दोहराने की कोशिश करूंगा .. आप किस क्षेत्र का उपयोग कर रहे हैं?
 – 
Deepak Singhal
2 मई 2020, 05:11
त्वरित उत्तर के लिए धन्यवाद दीपक। मुझे इसे एम 5 में बदलने के बाद भी वही त्रुटि (एम 3) मिल रही है। मैं DynamoDB (मुंबई क्षेत्र) से S3 में डेटा लोड करने का प्रयास कर रहा हूँ... डेटा पाइपलाइन us-east-1 में है
 – 
NikRED
2 मई 2020, 05:34
ऐसा लगता है जैसे Pipleline मुंबई क्षेत्र को #{myDDBRegion} के अनुसार ले जा रही थी। मैंने इसे पाइपलाइन GUI में us-east-1 में बदल दिया है। कुछ समय के लिए वर्तमान स्थिति WAITING_ON_DEPENDENCIES है... निश्चित कारण नहीं है
 – 
NikRED
2 मई 2020, 05:46

मुझे उसी समस्या का सामना करना पड़ रहा था जब मेरे पास डायनेमो डीबी टेबल और एस 3 बाल्टी यूएस-ईस्ट -2 क्षेत्र और पाइपलाइन यूएस-ईस्ट -1 में बनाई गई थी क्योंकि मुझे यूएस-ईस्ट -2 क्षेत्र में पाइपलाइन बनाने की अनुमति नहीं थी।

लेकिन, एक बार जब मैंने us-east-1 क्षेत्र में dynamoDB टेबल और s3 बकेट बनाया और फिर उसी क्षेत्र में पाइपलाइन भी बनाई, तो इसने m3.xlarge इंस्टेंस प्रकार के साथ भी अच्छा काम किया।

0
Ankur Aeran 3 सितंबर 2020, 10:03

मुझे लगता है कि इससे आपको मदद मिलनी चाहिए। यदि आप DynamoDBDataNode या resizeClusterBeforeRunning का उपयोग करते हैं, तो AWS आपको m3 का उपयोग करने के लिए बाध्य करेगा

https://aws.amazon.com/premiumsupport/knowledge-center/datapipeline-override-instance-type/?nc1=h_ls

0
Thinking 24 जून 2020, 07:11