मैंने एक अनुकूलित टीम साइट पर एक कस्टम निर्मित वेबपार्ट जोड़ने का प्रयास किया जिसे मैंने तब एक टेम्पलेट के रूप में सहेजा था। विचाराधीन वेबपार्ट ने मूल साइट के साथ ठीक काम किया। हालांकि, जब मैंने इस टेम्पलेट के आधार पर एक नई साइट बनाई (उसी सर्वर के भीतर जिस पर प्रश्न में वेबपार्ट तैनात किया गया था) जिस क्षेत्र में वेबपार्ट होना चाहिए था वह खाली था। क्या मुझे कुछ याद आ रहा है या क्या कस्टम वेबपार्ट को कस्टम साइट टेम्पलेट में परिनियोजित करना संभव नहीं है?

1
Sabry 26 सितंबर 2011, 16:09
क्या आपने कस्टम वेब पार्ट के अनुरूप सर्वर को लक्षित करने के लिए असेंबली तैनात की थी?
 – 
Madhur Ahuja
26 सितंबर 2011, 17:22
हां, मैंने सर्वर में टेम्पलेट जोड़ने से पहले विजुअल स्टूडियो के माध्यम से तैनात किया है
 – 
Sabry
26 सितंबर 2011, 19:05

1 उत्तर

सबसे बढ़िया उत्तर

यहां सिर्फ इसलिए अनुमान लगाया जा रहा है क्योंकि मैंने इसे आजमाया नहीं है, लेकिन जब आप पेज पर एक वेबपार्ट जोड़ते हैं तो आप उस विशिष्ट साइट के लिए उस पेज को अनिवार्य रूप से कस्टमाइज़ कर रहे होते हैं। वेबपार्ट स्थान केवल उस व्यक्तिगत पृष्ठ के लिए सामग्री डेटाबेस में संग्रहीत किया जाता है।

जब आप किसी साइट को टेम्पलेट के रूप में सहेजते हैं तो आप केवल संरचना को सहेज रहे होते हैं, इसलिए जब आप एक नई साइट का प्रावधान करते हैं तो अनुकूलित पृष्ठ नहीं होता है।

0
Lee Dale 27 सितंबर 2011, 17:44
आपके उत्तर ली के लिए धन्यवाद, मैंने वास्तव में इसे थोड़ी देर पहले हल किया था। पता चला कि वेबपार्ट एक अपवाद फेंक रहा था। मैंने इसे तब तक नहीं देखा जब तक मैंने लॉग की सही जांच नहीं की। मैंने वेबपार्ट कोड में बदलाव किया और इसे फिर से तैनात किया, और अब यह काम करता प्रतीत होता है। मदद के लिए धन्यवाद!!
 – 
Sabry
28 सितंबर 2011, 16:09