मैं उस jQuery के विशिष्ट संस्करण को कैसे सेट कर सकता हूं जिसे मैं डीएनएन में जावास्क्रिप्ट पुस्तकालयों का उपयोग करके कोड में उपयोग करना चाहता हूं? प्रलेखन हैं, लेकिन यह विशेष रूप से कोष्ठक में सटीक पैरामीटर नहीं दिखा रहा है। मैंने इस विकी पर एक नज़र डाली: http://www.dnnsoftware.com/wiki/ जावास्क्रिप्ट-पुस्तकालय#Usage_5

JavaScript.RequestRegistration(CommonJs.jQuery, 3.2.1);

संख्या वीएस में एक त्रुटि देती है। मुझे इसे किसमें बदलना चाहिए?

1
Tig7r 1 सितंबर 2017, 10:13
क्या आपने त्रुटि पर एक नज़र डाली? और 3.2.1 किस प्रकार का डेटाटाइप है? सही अधिभार Version है
 – 
VDWWD
1 सितंबर 2017, 14:00

1 उत्तर

सबसे बढ़िया उत्तर

उचित वाक्यविन्यास है:

JavaScript.RequestRegistration("jQuery", new Version(1, 9, 1));
3
Fix It Scotty 2 सितंबर 2017, 03:48
यह डीएनएन संस्करण 8.0.4 में काम नहीं करता है। मेरे पास कई संस्करणों के साथ एक AngularJs लाइब्रेरी है, लेकिन जब मैं 1.5.6 कहता हूं तो यह अभी भी सबसे हाल के संस्करण (1.6.6) को खींचता है। मुझे आश्चर्य है कि क्या कोई अपडेट था जो मुझे याद आया?
 – 
Mickers
13 नवम्बर 2017, 18:09
\Resources\Libraries में जांचें कि आपके पास एक AngularJs फ़ोल्डर है जिसके अंतर्गत फ़ोल्डर्स हैं जिनमें संस्करण वाले फ़ोल्डर हैं: "01_05_06" और "01_06_06"। यह तब किया जाना चाहिए था जब आपने जावास्क्रिप्ट लाइब्रेरी पैकेज स्थापित किया था।
 – 
Fix It Scotty
13 नवम्बर 2017, 22:56