मैंने अभी-अभी विजुअल स्टूडियो 2015 अपडेट 3 के लिए asp.net कोर टेम्प्लेट पैक इंस्टॉल किया है। मैंने इसे .visz फ़ाइल और विजुअल स्टूडियो 2015 >> टूल्स >> सेलेक्ट एक्सटेंशन्स और अपडेट्स दोनों का उपयोग करके किया है।

प्रत्येक मामले में यह बिना किसी समस्या के स्थापित होना प्रतीत होता था।

हालाँकि मैं ASP.NET Core Angular 2 Starter एप्लिकेशन नहीं बना सकता। हर बार जब मैं कोशिश करता हूं तो मुझे निम्न त्रुटि संदेश प्राप्त होता है: Microsoft.DotNet.Props नहीं मिला

The imported project "C:\Program Files (x86)\MSBuild\Microsoft\VisualStudio\v14.0\DotNet\Microsoft.DotNet.Props" was not found. Confirm that the path in the <import> declaration is correct, and that the file exists on disk.

त्रुटि संदेश मान्य है, वह फ़ाइल (वास्तव में संपूर्ण डॉटनेट फ़ोल्डर) डिस्क पर मौजूद नहीं है।

क्या किसी ने इसका सामना किया है और इसे सफलतापूर्वक हल किया है?

-1
Donald Evans 20 जुलाई 2018, 11:26
आपको .NET कोर प्रोजेक्ट्स के लिए विजुअल स्टूडियो 2017 या VSCode का उपयोग करना चाहिए।
 – 
Lex Li
20 जुलाई 2018, 15:41
कृपया मेरी टिप्पणी नीचे देखें।
 – 
Donald Evans
21 जुलाई 2018, 05:58
यह दावा करना कि «आपके पास सब कुछ है» वीएस2015 बेकार है, क्योंकि .NET कोर आधिकारिक तौर पर वहां समर्थित नहीं है। अपने प्रबंधक के पास आगे बढ़ें और अब आपको यही करना चाहिए।
 – 
Lex Li
21 जुलाई 2018, 06:58

2 जवाब

आप विजुअल स्टूडियो 2015 अपडेट 3 का उपयोग करके एएसपी.नेट कोर एंगुलर प्रोजेक्ट नहीं बना सकते क्योंकि विजुअल स्टूडियो 2015 अपडेट 3 में उस टेम्पलेट और 1.1 से अधिक एएसपी.नेट कोर संस्करण के लिए कोई समर्थन नहीं है। एएसपी का उपयोग करने के लिए आपको विजुअल स्टूडियो 2017 स्थापित करना होगा। .NET कोर कोणीय टेम्पलेट।

0
TanvirArjel 20 जुलाई 2018, 20:32
टेम्प्लेट विशेष रूप से वीएस 2015 अपडेट 3 के लिए है। मैंने इस आलेख में वर्णित निर्देशों का बिल्कुल पालन किया - code.msdn.microsoft.com/ASPNET-Core-Template-Pack-71bcde34। यहां भी - c-sharpcorner। कॉम/आलेख/….
 – 
Donald Evans
21 जुलाई 2018, 05:58
ओह! समझ लिया! यह थर्ड पार्टी टेम्प्लेट है। यहां देखें ASP.NET कोर संस्करण 1.0 है.. आप ASP.NET कोर संस्करण 1.0 पर प्रोजेक्ट क्यों चाहते हैं जबकि वर्तमान स्थिर संस्करण 2.1 है।
 – 
TanvirArjel
21 जुलाई 2018, 06:02
मैं कोणीय 2 और ASP.NET कोर के साथ विकास सीख रहा हूँ। यह मेरी विशेषज्ञता का क्षेत्र नहीं है। मैं सिर्फ सीखने के उद्देश्य से लेख को पूरा करना चाहता था।
 – 
Donald Evans
21 जुलाई 2018, 06:17
इसके अतिरिक्त मैं कार्यस्थल में विजुअल स्टूडियो 2015 का उपयोग करता हूं। मेरे पास बस इतना ही है।
 – 
Donald Evans
21 जुलाई 2018, 06:24
जैसा कि आप सीख रहे हैं तो विजुअल स्टूडियो 2017 का उपयोग करने में क्या गलत है?
 – 
TanvirArjel
21 जुलाई 2018, 06:32

उनकी सहायता के लिए सभी को धन्यवाद, हालांकि ऐसा प्रतीत होता है कि दिए गए उत्तरों की तुलना में अधिक प्रश्न हैं।

मैं सिर्फ वीएस 2017 स्थापित करूंगा और उससे सीखूंगा।

0
Donald Evans 21 जुलाई 2018, 07:04