मैंने अभी-अभी अपने Ubuntu Server में Symfony 3.4.15 को कॉन्फ़िगर किया है और स्वागत पृष्ठ काम करता है, लेकिन जब मैं एक नया पेज बनाना चाहता हूं, उदाहरण के लिए /होम, एक नियंत्रक के साथ यह काम नहीं करता है:

पता नहीं चला

अनुरोधित यूआरएल /होम इस सर्वर पर नहीं मिला। अपाचे/2.4.18 (उबंटू) सर्वर 167.99.90.60 पोर्ट 80 . पर

मैं सिम्फनी दस्तावेज़ीकरण में सभी चरणों का पालन करता हूं, लेकिन यह काम नहीं करता है ...

मैंने पढ़ा है कि समस्या मेरे Apache2 कॉन्फ़िगरेशन के कारण हुई है, लेकिन मुझे नहीं पता कि इसे कैसे हल किया जाए।

मेरे पास मेरे उबंटू सर्वर में LAMP स्थापित है।

Apache2 कॉन्फ़िगरेशन कुछ इस तरह है:

<Directory />
        Options FollowSymLinks
        AllowOverride None
        Require all denied
</Directory>

<Directory /usr/share>
        AllowOverride None
        Require all granted
</Directory>

<Directory /var/www/my-project/public>
        Options FollowSymLinks
        AllowOverride All
        Require all granted
</Directory>

#<Directory /srv/>
#       Options Indexes FollowSymLinks
#       AllowOverride None
#       Require all granted
#</Directory>

यहाँ मेरा वर्चुअल होस्ट फ़ाइल कॉन्फ़िगरेशन है:

<VirtualHost *:80>
        # The ServerName directive sets the request scheme, hostname $
        # the server uses to identify itself. This is used when creat$
        # redirection URLs. In the context of virtual hosts, the Serv$
        # specifies what hostname must appear in the request's Host: $
        # match this virtual host. For the default virtual host (this$
        # value is not decisive as it is used as a last resort host r$
        # However, you must set it for any further virtual host expli$
        #ServerName www.example.com

        ServerAdmin webmaster@localhost
        DocumentRoot /var/www/my-project/public

        # Available loglevels: trace8, ..., trace1, debug, info, noti$
        # error, crit, alert, emerg.
        # It is also possible to configure the loglevel for particular
        # modules, e.g.
        #LogLevel info ssl:warn

        ErrorLog ${APACHE_LOG_DIR}/error.log
        CustomLog ${APACHE_LOG_DIR}/access.log combined

        # For most configuration files from conf-available/, which are
        # enabled or disabled at a global level, it is possible to
        # include a line for only one particular virtual host. For ex$
        # following line enables the CGI configuration for this host $
        # after it has been globally disabled with "a2disconf".
        #Include conf-available/serve-cgi-bin.conf
</VirtualHost>

# vim: syntax=apache ts=4 sw=4 sts=4 sr noet

कोई विचार?

1
HessianMad 30 अगस्त 2018, 16:57
मेरा सुझाव है कि आप अपने कॉन्फ़िगरेशन की तुलना symfony.com/doc/current/setup में सुझाए गए कॉन्फ़िगरेशन से करें /web_server_configuration.html. उदाहरण के लिए, यह आवश्यक पुनर्लेखन नियमों को याद करता है।
 – 
xabbuh
31 अगस्त 2018, 15:12
ओह, और यदि आपने सिम्फनी फ्लेक्स का उपयोग करके अपने एप्लिकेशन को बूटस्ट्रैप किया है तो अपाचे पैक स्थापित करना (चलना composer require symfony/apache-pack) आपकी समस्या को भी हल कर सकता है।
 – 
xabbuh
31 अगस्त 2018, 15:13

2 जवाब

सबसे बढ़िया उत्तर

समस्या यह थी कि मैं अपनी .htaccess फ़ाइल de /public फ़ोल्डर के अंदर बनाना भूल गया था।

0
HessianMad 1 सितंबर 2018, 13:47

मेरा सबसे अच्छा अनुमान है कि आपके पास url अधिलेखित सक्षम नहीं है।

क्या आपने सिम्फनी डेवलपमेंट सर्वर का उपयोग करने की कोशिश की है?

सुनिश्चित करें कि आपकी अपाचे कॉन्फ़िगरेशन फ़ाइल में hthis जैसा कुछ है (आमतौर पर /etc/apache2/apache2.conf में):

<Directory /var/www/>
    Options -Indexes +FollowSymLinks
    AllowOverride All
    Require all granted
</Directory>
0
Magnesium 30 अगस्त 2018, 17:02
नहीं, मैंने सिम्फनी विकास सर्वर की कोशिश नहीं की है। यह एक अच्छा विचार है? मैंने यह कोशिश की "> stackoverflow.com/questions/869092/… और जो आपने apache2 कॉन्फ़िग फ़ाइल के बारे में कहा है लेकिन काम नहीं करता है... :(
 – 
HessianMad
30 अगस्त 2018, 17:00
2
हां, सिम्फनी परीक्षण सर्वर आपको विकास प्रक्रिया में बहुत सारी परेशानी से बचाएगा। बस php bin/console सर्वर चलाएं: अपनी एप्लिकेशन डायरेक्टरी में शुरू करें और localhost:8000 symfony.com/doc/current/setup/built_in_web_server.html अपनी अपाचे कॉन्फ़िगरेशन फ़ाइल की जांच करना भी सुनिश्चित करें।
 – 
Magnesium
30 अगस्त 2018, 17:03
जैसा कि आप मेरे नए संपादन में देख सकते हैं, मैंने अपाचे कॉन्फ़िगरेशन फ़ाइल को बदलने का प्रयास किया लेकिन फिर भी काम नहीं किया ...
 – 
HessianMad
30 अगस्त 2018, 17:13
क्या आपने जाँच की है कि क्या यह इसके बाद सक्षम है? stackoverflow.com/questions/7337724/… आप अपना वर्चुअल होस्ट कॉन्फ़िगरेशन भी पोस्ट कर सकते हैं, अधिक जानकारी होने से कोई नुकसान नहीं हो सकता है।
 – 
Magnesium
30 अगस्त 2018, 17:18
मैंने अपने वर्चुअलहोस्ट फ़ाइल कॉन्फ़िगरेशन के साथ प्रश्न अपडेट किया :)
 – 
HessianMad
30 अगस्त 2018, 17:23