मैं Google क्लाउड में एक गहन शिक्षण मॉडल चलाने के लिए एक डॉकर छवि बना रहा हूं। मैं निर्भरताओं में से एक के रूप में tensorflow का उपयोग कर रहा हूं और इसे requirements.txt में निर्दिष्ट करता हूं। मुझे समझ में नहीं आया कि निर्भरता संस्करण को कैसे निर्दिष्ट किया जाए और छवि टेंसरफ़्लो 2.0 के साथ बनाई गई थी।

मॉडल के विभिन्न कार्यान्वयनों का परीक्षण करते समय मुझे समस्याओं का सामना करना पड़ा जब कोड tensorflow के पुराने संस्करणों के लिए लिखा गया था। अंत में मैंने इसे कुछ रिफैक्टरिंग के बाद काम किया।

निर्भरता के विशिष्ट संस्करण को requirements.txt में जोड़ने का सही तरीका क्या है? उदाहरण के लिए, मुझे tensorflow 1.14.

Dockerfile:

FROM python:3.6
WORKDIR /app
COPY requirements.txt /app
RUN pip install -r ./requirements.txt
COPY app.py /app
CMD ["python", "app.py"]~

requirements.txt:

keras
tensorflow
flask
gevent
pillow
requests
-1
samba 3 मार्च 2020, 18:49
1
यह आपकी मदद कर सकता है मेरा मानना ​​है कि आपको केवल आवश्यकता txt पर संस्करण निर्दिष्ट करने की आवश्यकता है।
 – 
Mefitico
3 मार्च 2020, 18:54

2 जवाब

आप आवश्यकताएँ.txt फ़ाइल में एक संस्करण निर्दिष्ट कर सकते हैं.. जैसे

tensorflow==1.14

यह भी देखें: https://pip.readthedocs.io/en/1.1/requirements.html

2
Bastian 3 मार्च 2020, 18:54

जैसा कि @Bastian ने कहा था कि आप tensorflow==1.14 के साथ एक संस्करण निर्दिष्ट कर सकते हैं

इसके अलावा आप इस आदेश के साथ अपने स्थानीय विकास पर्यावरण से वह सूची बना सकते हैं:

python3 -m pip freeze > requirements.txt

python3 भिन्न हो सकते हैं। यह python, py या py3 हो सकता है।

अपने सभी पायथन मॉड्यूल को एक संस्करण में लॉक करना एक अच्छा विचार है। यह भी सुनिश्चित करें कि आप सभी वातावरणों में एक ही पायथन संस्करण का उपयोग कर रहे हैं। आप अपने उपयोग किए गए पायथन संस्करण को python3 -V के साथ देख सकते हैं

1
Tin Nguyen 3 मार्च 2020, 18:57