MacOS विशेषज्ञों को कॉल करना... स्पंदन पर पॉड इंस्टॉल पर इस समस्या को देखने में आपकी सहायता की सराहना करें-- विवरण यहाँ हैं

command used
/usr/local/bin/pod install --verbose

   CocoaPods : 1.9.1
        Ruby : ruby 2.6.3p62 (2019-04-16 revision 67580) [universal.x86_64-darwin19]
    RubyGems : 3.1.2
        Host : Mac OS X 10.15.4 (19E266)
       Xcode : 11.4 (11E146)
         Git : git version 2.24.1 (Apple Git-126)
Ruby lib dir : /System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib

cocoapods-deintegrate : 1.0.4
cocoapods-plugins     : 1.0.0
cocoapods-search      : 1.0.0
cocoapods-stats       : 1.1.0
cocoapods-trunk       : 1.4.1
cocoapods-try         : 1.1.0

त्रुटि

RuntimeError - [Xcodeproj] Unknown object version.
/Library/Ruby/Gems/2.6.0/gems/xcodeproj-1.15.0/lib/xcodeproj/project.rb:227:in
0
topspindex 2 अप्रैल 2020, 10:43
क्या इससे आपके सवाल का जवाब मिलता है? पॉड के साथ क्या हो रहा है?
 – 
Kirill Matrosov
2 अप्रैल 2020, 11:06

2 जवाब

क्या मदद कर सकता है:

gem install cocoapods --pre

और शायद

gem update

यदि यह मदद नहीं करता है, तो जांचें कि क्या आपका प्रोजेक्ट प्रारूप सही है: यहां छवि विवरण दर्ज करें

स्रोत: https://github.com/CocoaPods/CocoaPods/issues/7697 https://github.com/CocoaPods/CocoaPods/issues/7458

0
Nuts 2 अप्रैल 2020, 11:23
इसने भी मदद की, लेकिन मेरी वास्तविक समस्या xcodeproject सेटिंग्स थी, जो कुछ निर्भरताएं नहीं मिल सकती हैं।
 – 
topspindex
3 अप्रैल 2020, 05:54

ठीक करने के लिए 2 कदम ..

मणि कोकोपोड्स स्थापित करें -- पहले मणि स्थापित करें mygem --user-install

और वोइला। आपकी कई दिनों की समस्या का समाधान हो गया है...

1
topspindex 2 अप्रैल 2020, 12:32