इसलिए, मैं यहां नया हूं, बस एंड्रॉइड स्टूडियो स्थापित किया है और फिर एक बुनियादी गतिविधि बनाना चाहता हूं। लेकिन बात यह है कि वे चाहते हैं कि मैं एसडीके और एचएक्सएम स्थापित करूं जो एसडीके प्रबंधक के माध्यम से स्थापित नहीं किया जा रहा है। मैंने बहुत कोशिश की है और इससे छुटकारा पाने के लिए स्टैक-ओवरफ्लो में बताए गए सभी तरीकों का इस्तेमाल किया है लेकिन उनका कोई भी तरीका काम नहीं कर रहा है।

enter image description here

76
nav2236 14 मार्च 2020, 11:35
क्या आप हमें अपने ऐप की build.gradle फ़ाइल दिखा सकते हैं?
 – 
Edric
14 मार्च 2020, 11:47

10 जवाब

सबसे पहले! आपको अपने एसडीके प्रबंधक को अपडेट करने की आवश्यकता है कि बहुत आवश्यक उपकरण हैं: टूल प्लेटफॉर्म टूल्स टूल्स और एंड्रॉइड एमुलेटर का निर्माण करें

.....

अब LOGCAT में जाएं, config sdk पर क्लिक करें ..... इसे नवीनतम पर रखें और प्रत्येक बार के लिए ऑटोकॉन्फिग बटन पर क्लिक करें।

यही इसका पुनर्निर्माण है! आपने 100%% सफल त्रुटि समाधान के साथ काम किया है, आपकी गतिविधि.एक्सएमएल फ़ाइल बिना किसी चेतावनी या त्रुटि के प्रदर्शित की जाएगी!

6
suraj pragada 15 अप्रैल 2020, 15:04

मुझे एक ही समस्या का सामना करना पड़ता है। सबसे पहले, एपीआई स्तर 28 स्थापित करें और एंड्रॉइड स्टूडियो को पुनरारंभ करें।

7
Dipak Kumar Bhatiya 10 अप्रैल 2020, 17:41

टूल्स-> एसडीके मैनेजर-> एपीआई लेवल 28 इंस्टॉल करें और फिर रीस्टार्ट करें।

112
Mohammad Kashem 6 मई 2020, 09:53
नोट: सुनिश्चित करें कि 29 भी पूरी तरह से स्थापित है।
 – 
Arjjun
30 अगस्त 2020, 23:13
मुझे आवश्यक एपीआई स्थापित करने के लिए "व्यवस्थापक के रूप में चलाएं" का उपयोग करके एंड्रॉइड स्टूडियो खोलना पड़ा। अन्यथा, स्थापना विफल हो रही थी।
 – 
VijayKP
12 सितंबर 2020, 12:29
13
एंड्रॉइड स्टूडियो 4.1 के लिए, एसडीके प्रबंधक एंड्रॉइड स्टूडियो पर स्थित है-> प्राथमिकताएं-> उपस्थिति और व्यवहार-> सिस्टम सेटिंग्स-> एंड्रॉइड एसडीके
 – 
Orange
2 नवम्बर 2020, 05:44
आपको अपने प्रत्येक पुस्तकालय द्वारा उपयोग किए जाने वाले एसडीके संस्करण की आवश्यकता है। मैंने sdk 30 का उपयोग किया, लेकिन कुछ पुस्तकालयों ने 29 और 31 का उपयोग किया। आप देख सकते हैं कि प्रत्येक पुस्तकालय फ़ाइल - परियोजना संरचना - मॉड्यूल में क्या उपयोग करता है।
 – 
Simon Bengtsson
21 नवम्बर 2021, 01:51
  1. टूल्स पर जाएं
  2. एसडीके प्रबंधक का चयन करें
  3. एसडीके प्लेटफॉर्म के तहत एंड्रॉइड 9.0 (पाई) (एपीआई 28) का चयन करें
  4. फिर एपीआई लागू करें और डाउनलोड करें
35
hexhad 7 नवम्बर 2020, 22:05
1
न्यूनतम शब्द, अधिकतम प्रभावी :)
 – 
Ice
11 पद 2020, 17:15
1
इशारा करते हुए, कि एंड्रॉइड 9.0 एपीआई 28 है, मुझे जिस मदद की ज़रूरत थी।
 – 
Kim Hogeling
25 मई 2021, 16:18

अपने एंड्रॉइड स्टूडियो को एंड्रॉइड 4 में पुनर्स्थापित और अपग्रेड करने के बाद, मुझे उसी चुनौती का सामना करना पड़ा। लेकिन मैंने जो किया वह टूल-> एसडीके मैनेजर पर जाना था और फिर कुछ अन्य एपीआई इंस्टॉल करना था जिसमें त्रुटि संदेश एपीआई 28 स्थापित नहीं था और यह ठीक काम करता है।

4
aweda azeez 29 जून 2020, 04:07
  1. 'वेलकम स्क्रीन' देखने के लिए एंड्रॉइड स्टूडियो खोलें (यदि कोई प्रोजेक्ट सीधे खुलेगा, तो आप 'वेलकम स्क्रीन' पर जाने के लिए इसे बंद कर सकते हैं)

  2. एसडीके प्रबंधक में एक 'कॉन्फ़िगर करें' मेनू है (ड्रॉप डाउन सूची से पहला विकल्प)।

  3. खोलें, फिर आवश्यक एंड्रॉइड एसडीके संस्करण चुनें, ठीक दबाएं और डाउनलोड की प्रतीक्षा करें (सब कुछ स्थापित होने तक इसमें कुछ समय लगेगा)।

  4. इसके बाद, जब आप कोई प्रोजेक्ट खोलते हैं, तो 'टूल्स' मेनू सभी अनुपलब्ध सामग्री के साथ अपडेट हो जाता है।

4
Radu Comaniciu 18 पद 2020, 12:55

यदि आपने पहले ही कोई प्रोजेक्ट खोल लिया है, तो "SDK प्रबंधक" मुख्य स्क्रीन पर पाया जा सकता है SDK Manager Icon

फिर आप लापता एसडीके जोड़ सकते हैं।

1
Maurizio Lo Bosco 27 जुलाई 2021, 23:19

इंटरनेट चालू करें और उसमें एंड्रॉइड स्टूडियो खोलें "टूल्स-> एसडीके मैनेजर" चुनें और एपीआई लेवल 29 चुनें, इसे डाउनलोड करें और लागू करें। एंड्रॉइड स्टूडियो बंद करें और फिर से खोलें 💯✨

0
Varun 29 जुलाई 2020, 09:11

ऐप लेवल ग्रैडल फ़ाइल में अपने प्रोजेक्ट के बिल्डटूलवर्सन की जाँच करें। फिर जांचें कि आपने एसडीके संस्करण स्थापित किया है या नहीं। आप इसे एवीडी मैनेजर पर देख सकते हैं। यदि आपने buildToolsVersion sdk इंस्टॉल नहीं किया है तो पहले इंस्टॉल करें और प्रोजेक्ट का पुनर्निर्माण करें।

भूतपूर्व। यदि आपका बिल्डटूल वर्जन 28 है, तो आपको एंड्रॉइड 9.0 (पाई) - एपीआई लेवल 28 एसडीके इंस्टॉल करना चाहिए।

0
ruwanmadushanka 7 नवम्बर 2020, 09:15

मुझे उसी समस्या का सामना करना पड़ा लेकिन मैंने एंड्रॉइड स्टूडियो की स्थापना रद्द कर दी और इंटरनेट से कनेक्ट होने के दौरान इसे फिर से इंस्टॉल किया। इसने अपडेटेड एसडीके और अन्य टूल्स को स्वयं डाउनलोड किया। यह पूरी तरह से काम करता है

2
Insookwa 11 मई 2020, 17:35