मुझे यह त्रुटि php7.2 में मिल रही है। मैं सिम्फनी 4 का उपयोग कर रहा हूं।

Warning: Use of undefined constant XML_PI_NODE - assumed 'XML_PI_NODE' (this will throw an Error in a future version of PHP)

यह त्रुटि रेखा है।

in var/cache/dev/ContainerIZRQnYa/getSerializerService.php (line 55)
return $this->services['serializer'] = new \Symfony\Component\Serializer\Serializer([0 => new \Symfony\Component\Serializer\Normalizer\JsonSerializableNormalizer(), 1 => new \Symfony\Component\Serializer\Normalizer\DateTimeNormalizer(), 2 => new \Symfony\Component\Serializer\Normalizer\ConstraintViolationListNormalizer(), 3 => new \Symfony\Component\Serializer\Normalizer\DateIntervalNormalizer(), 4 => new \Symfony\Component\Serializer\Normalizer\DataUriNormalizer(), 5 => new \Symfony\Component\Serializer\Normalizer\ArrayDenormalizer(), 6 => new \Symfony\Component\Serializer\Normalizer\ObjectNormalizer($a, new \Symfony\Component\Serializer\NameConverter\MetadataAwareNameConverter($a), new \Symfony\Component\PropertyAccess\PropertyAccessor(false, false, new \Symfony\Component\Cache\Adapter\ArrayAdapter(0, false)), NULL, new \Symfony\Component\Serializer\Mapping\ClassDiscriminatorFromClassMetadata($a))], [0 => new \Symfony\Component\Serializer\Encoder\XmlEncoder(), 1 => new \Symfony\Component\Serializer\Encoder\JsonEncoder(), 2 => new \Symfony\Component\Serializer\Encoder\YamlEncoder(), 3 => new \Symfony\Component\Serializer\Encoder\CsvEncoder()]);

मैंने पहले ही कैश साफ़ कर दिया है और सभी अनुमतियाँ पहले ही सेट हो चुकी हैं। मुझे क्या करना चाहिए?

6
Cagrison 5 अप्रैल 2020, 21:55
 – 
u_mulder
5 अप्रैल 2020, 22:02
Php 7-2xml पहले से ही मेरे सर्वर पर स्थापित है, पहले कोशिश की।
 – 
Cagrison
5 अप्रैल 2020, 22:06
क्या आपको इसके लिए कोई फिक्स मिला?
 – 
mickadoo
29 नवम्बर 2020, 22:48

1 उत्तर

सबसे बढ़िया उत्तर

मुझे भी यही समस्या थी, मैंने PHP XML का उपयोग करके स्थापित किया था

sudo apt install php7.4-xml

लेकिन अभी भी मिल रहा था। मेरे दौड़ने के बाद यह चला गया:

install zlib1g-dev libxml2-dev

2
mickadoo 29 नवम्बर 2020, 23:52