मैं डार्ट में चर के लिए टाइपपीफ का उपयोग करना चाहता हूं इसलिए मैं न्यूनतम डार्ट संस्करण को 2.14.0 पर अपडेट करने का प्रयास कर रहा हूं।
जब मैं पर्यावरण को में बदलता हूं

environment:
  sdk: ">=2.14.0 <3.0.0"

मुझे निम्नलिखित त्रुटि मिलती है

[project] flutter pub get
Running "flutter pub get" in project...                      
The current Dart SDK version is 2.14.0-377.0.dev.

Because project requires SDK version >=2.14.0 <3.0.0, version solving failed.
pub get failed (1; Because project requires SDK version >=2.14.0 <3.0.0, version solving failed.)
exit code 1

अब मैं उलझन में हूँ कि >= का क्या अर्थ है यदि मेरा संस्करण 2.14.something है और यह >=2.14.0 की शर्त को पूरा नहीं करता है।
कोई विचार क्या हो रहा है?

flutter doctor
[√] Flutter (Channel dev, 2.5.0-5.0.pre, on Microsoft Windows [Version 10.0.19043.1110], locale en-GB)
...
4
Chris 10 अगस्त 2021, 12:12
आपका एसडीके देव मोड में है एक रिलीज करने के लिए डार्क एसडीके को अपडेट करने का प्रयास करें
 – 
Asim Jawad
10 अगस्त 2021, 12:19
क्या आपका मतलब स्थिर रिलीज है? यदि मैं सही ढंग से देखूं तो वर्तमान में स्थिर रिलीज 2.13.4 संस्करण है।
 – 
Chris
10 अगस्त 2021, 12:25
हां, मैंने -0 रखा है और अब मैं चर के लिए टाइपपीफ का उपयोग कर सकता हूं। धन्यवाद। आप अपनी टिप्पणी को उत्तर के रूप में पोस्ट कर सकते हैं और मैं इसे स्वीकार करूंगा।
 – 
Chris
10 अगस्त 2021, 12:37

1 उत्तर

सबसे बढ़िया उत्तर

आपके द्वारा इंस्टॉल किए गए डार्ट एसडीके का संस्करण 2.14.0-377.0.dev है; -377.0.dev भाग इंगित करता है कि यह एक विकास रिलीज़ (एक पूर्व-रिलीज़) है, जो आपके pubspec.yaml बाधाओं के अनुसार 2.14.0 के स्थिर संस्करण की आवश्यकता को पूरा नहीं कर सकता है।

आप इसके बजाय sdk: ">=2.14.0-0 <3.0.0" सेट कर सकते हैं (-0 पर ध्यान दें) यह इंगित करने के लिए कि आप 2.14.0 के विकास संस्करणों को स्वीकार करते हैं।

2
jamesdlin 11 अगस्त 2021, 07:37