मैं एक udemy पाठ्यक्रम से एक ट्यूटोरियल का अनुसरण कर रहा हूं और हाल ही में मैंने एक नया पीसी बनाया है, इसलिए मेरे कोड को संग्रहीत करने वाली हार्ड ड्राइव अभी द्वितीयक है। जब मैं कोड संकलित करता हूं, तो यह मुझे निम्न त्रुटि देता है। इसे बेहतर ढंग से समझाने के लिए, मैं अपने कोड में एक चेतावनी की एक तस्वीर पोस्ट कर रहा हूं लेकिन मुझे पूरा यकीन है कि यह एक त्रुटि स्पंदन है जैसा कि आमतौर पर आयात के साथ होता है। कोड में त्रुटि मैंने cmd से एक डिफ़ॉल्ट ऐप बनाकर एक टेस्ट ऐप चलाने की कोशिश की है और यह ठीक काम करता है। तो जाहिर है, स्पंदन डॉक्टर कोई त्रुटि नहीं दिखाता है। त्रुटि दोहराई जाने वाली और लंबी है इसलिए मैं इसमें से कुछ को नीचे चिपका रहा हूं।

त्रुटि-

Invalid depfile: D:\WorkSpace\Code\Flutter\Image App\image_app\.dart_tool\flutter_build\8f0d0eee9ef614ed024ca7691a333af8\kernel_snapshot.d
Invalid depfile: D:\WorkSpace\Code\Flutter\Image App\image_app\.dart_tool\flutter_build\8f0d0eee9ef614ed024ca7691a333af8\kernel_snapshot.d

Compiler message:
Error: Could not resolve the package 'http' in 'package:http/http.dart'.
lib/src/app.dart:5:8: Error: Expected ';' after this.
import 'widgets/image_list.dart;'
       ^^^^^^^^^^^^^^^^^^^^^^^^^^
lib/src/app.dart:2:8: Error: Not found: 'package:http/http.dart'
import 'package:http/http.dart' show get; //Only need get so we only care about one Get fuction
       ^
lib/src/app.dart:5:8: Error: Error when reading 'lib/src/widgets/image_list.dart;': The system cannot find the file specified.

import 'widgets/image_list.dart;'
       ^
/C:/src/flutter/packages/flutter/lib/src/material/bottom_navigation_bar.dart:9:8: Error: Error when reading '/C:/Users/dluck/AppData/Roaming/Pub/Cache/hosted/pub.dartlang.org/vector_math-2.0.8/lib/vector_math_64.dart': The system cannot find the path specified.

import 'package:vector_math/vector_math_64.dart' show Vector3;
       ^
/C:/src/flutter/packages/flutter/lib/widgets.dart:15:1: Error: Error when reading '/C:/Users/dluck/AppData/Roaming/Pub/Cache/hosted/pub.dartlang.org/vector_math-2.0.8/lib/vector_math_64.dart': The system cannot find the path specified.

export 'package:vector_math/vector_math_64.dart' show Matrix4;
^
/C:/src/flutter/packages/flutter/lib/rendering.dart:31:1: Error: Error when reading '/C:/Users/dluck/AppData/Roaming/Pub/Cache/hosted/pub.dartlang.org/vector_math-2.0.8/lib/vector_math_64.dart': The system cannot find the path specified.

export 'package:vector_math/vector_math_64.dart' show Matrix4;
^
/C:/src/flutter/packages/flutter/lib/src/widgets/implicit_animations.dart:8:8: Error: Error when reading '/C:/Users/dluck/AppData/Roaming/Pub/Cache/hosted/pub.dartlang.org/vector_math-2.0.8/lib/vector_math_64.dart': The system cannot find the path specified.

import 'package:vector_math/vector_math_64.dart';
       ^
/C:/src/flutter/packages/flutter/lib/src/widgets/transitions.dart:8:8: Error: Error when reading '/C:/Users/dluck/AppData/Roaming/Pub/Cache/hosted/pub.dartlang.org/vector_math-2.0.8/lib/vector_math_64.dart': The system cannot find the path specified.

import 'package:vector_math/vector_math_64.dart' show Matrix4;
       ^
/C:/src/flutter/packages/flutter/lib/src/widgets/widget_inspector.dart:27:8: Error: Error when reading '/C:/Users/dluck/AppData/Roaming/Pub/Cache/hosted/pub.dartlang.org/vector_math-2.0.8/lib/vector_math_64.dart': The system cannot find the path specified.

import 'package:vector_math/vector_math_64.dart';
       ^
/C:/src/flutter/packages/flutter/lib/foundation.dart:12:1: Error: Error when reading '/C:/Users/dluck/AppData/Roaming/Pub/Cache/hosted/pub.dartlang.org/meta-1.1.8/lib/meta.dart': The system cannot find the path specified.

C:/src/flutter/packages/flutter/lib/src/foundation/node.dart:90:4: Error: Getter not found: 'mustCallSuper'.
  @mustCallSuper
   ^^^^^^^^^^^^^
/C:/src/flutter/packages/flutter/lib/src/foundation/node.dart:90:4: Error: This can't be used as metadata; metadata should be a reference to a compile-time constant variable, or a call to a constant constructor.
  @mustCallSuper
   ^
/C:/src/flutter/packages/flutter/lib/src/foundation/node.dart:104:4: Error: Getter not found: 'mustCallSuper'.
  @mustCallSuper
   ^^^^^^^^^^^^^
/C:/src/flutter/packages/flutter/lib/src/foundation/node.dart:104:4: Error: This can't be used as metadata; metadata should be a reference to a compile-time constant variable, or a call to a constant constructor.
  @mustCallSuper
   ^
/C:/src/flutter/packages/flutter/lib/src/foundation/node.dart:118:4: Error: Getter not found: 'protected'.
  @protected
   ^^^^^^^^^
/C:/src/flutter/packages/flutter/lib/src/foundation/node.dart:118:4: Error: This can't be used as metadata; metadata should be a reference to a compile-time constant variable, or a call to a constant constructor.
  @protected
   ^
/C:/src/flutter/packages/flutter/lib/src/foundation/node.dart:119:4: Error: Getter not found: 'mustCallSuper'.
  @mustCallSuper
   ^^^^^^^^^^^^^
/C:/src/flutter/packages/flutter/lib/src/foundation/node.dart:119:4: Error: This can't be used as metadata; metadata should be a reference to a compile-time constant variable, or a call to a constant constructor.
  @mustCallSuper
   ^
/C:/src/flutter/packages/flutter/lib/src/foundation/node.dart:139:4: Error: Getter not found: 'protected'.
  @protected
   ^^^^^^^^^

C:/src/flutter/packages/flutter/lib/src/semantics/semantics.dart:3970:4: Error: This can't be used as metadata; metadata should be a reference to a compile-time constant variable, or a call to a constant constructor.
  @required TextDirection thisTextDirection,
   ^
/C:/src/flutter/packages/flutter/lib/src/semantics/semantics.dart:3971:4: Error: Getter not found: 'required'.
  @required TextDirection otherTextDirection,
   ^^^^^^^^
/C:/src/flutter/packages/flutter/lib/src/semantics/semantics.dart:3971:4: Error: This can't be used as metadata; metadata should be a reference to a compile-time constant variable, or a call to a constant constructor.
  @required TextDirection otherTextDirection,
   ^
U
nhandled exception:
FileSystemException(uri=org-dartlang-untranslatable-uri:
package%3Ahttp%2Fhttp.dart; message=StandardFileSystem only supports file:* and data:* URIs)
#0      StandardFi
leSystem.entityForUri (package:front_end/src/api_prototype/standard_file_system.dart:33:7)
#1      asFileU
ri (package:vm/kernel_front_end.dart:604:37)
#
2      writeDepfile (package:vm/kernel_front
_end.dart:799:21)
<asynchronous suspension>
#
3      FrontendCompiler.compile (package:fron
tend_server/frontend_server.dart:472:15)
<asynchronous 
suspension>
#4      _FlutterFrontendCompiler.comp
ile (package:flutter_frontend_server/server.dar
t:38:22)
#5      starter (package:flutter_fronte
nd_server/server.dart:149:27)
#6      main (f
ile:///C:/b/s/w/ir/cache/builder/src/flutter/fl
utter_frontend_server/bin/starter.dart:8:30)
#7    
  _startIsolate.<anonymous closure> (dart:isol
ate-patch/isolate_patch.dart:305:32)
#8      _RawRec
eivePortImpl._handleMessage (dart:isolate-patch
/isolate_patch.dart:174:12)

Target kernel_snapshot failed: Exception: Errors during snapshot creation: null
build failed.

FAILURE: Build failed with an exception.

* Where:
Script 'C:\src\flutter\packages\flutter_tools\gradle\flutter.gradle' line: 780

* What went wrong:
Execution failed for task ':app:compileFlutterBuildDebug'.
> Process 'command 'C:\src\flutter\bin\flutter.bat'' finished with non-zero exit value 1

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

* Get more help at https://help.gradle.org

BUILD FAILED in 6s
Gradle task assembleDebug failed with exit code 1
Exited (sigterm)
18
greenycodeskii 26 मार्च 2020, 20:20
क्या आपने "स्पंदन पब प्राप्त करें" आदेश का प्रयास किया था? क्योंकि ऐसा लगता है कि आपका कोई पैकेज नहीं मिला।
 – 
Arun Yogeshwaran
26 मार्च 2020, 20:44

13 जवाब

सबसे बढ़िया उत्तर

ठीक है तो मुझे पता चला कि जब से मैंने पीसी बदला है, मुझे एक फाइल की अनुमतियां बदलने की जरूरत है। यहाँ का पालन करें https://github.com/simolus3/moor/issues/224

5
greenycodeskii 28 मार्च 2020, 12:54

मुझे वही त्रुटि मिली और मैं एक उदमी पाठ्यक्रम का भी अनुसरण कर रहा हूं।
मैंने flutter pub get की कोशिश की और यह काम कर गया।

21
סטנלי גרונן 9 अगस्त 2020, 10:13

मुझे भी इसी समस्या का सामना करना पड़ा और मैं "स्पंदन साफ" कमांड चलाकर हल करता हूं। https://github.com/flutter/flutter/issues/21053

7
vinit jain 10 अगस्त 2020, 18:51

कभी-कभी मेरे साथ भी ऐसा होता है। मैंने या तो परिवर्तित कोड को हटा दिया है या इसे कमांड में परिवर्तित कर दिया है उदाहरण के लिए यहां मैंने दर्ज किया है:

import 'dart:html';

, और मेरी त्रुटि इसे हटाने या इसे एक टिप्पणी में बदलने के बाद तय की गई थी

// import 'dart:html';
7
VolcanoCoder 18 जिंदा 2021, 09:19

आपको प्रोजेक्ट में प्रोजेक्ट रन "स्पंदन क्लीन" को साफ करने की आवश्यकता है और बाद में प्रोजेक्ट को सामान्य चलाएं

5
francisco nicolas angulo estay 3 सितंबर 2020, 20:02
Invalid depfile: D:\...\f5\.dart_tool\flutter_build\8e234dd4da26339b660f6097cc2a271a\kernel_snapshot.d

इस स्थान पर kernel_snapshot.d और kernel_snapshot.stamp फ़ाइलें हटाएं:

your flutter project\.dart_tool\flutter_build\8e234dd4da26339b660f6097cc2a271a
4
lagivan 9 फरवरी 2021, 22:34

यह वास्तव में एक साधारण समस्या है, आपको बस इतना करना है कि नीचे टर्मिनल पर जाएं और flutter clean टाइप करें और बस इतना ही।

1
Henry2 24 नवम्बर 2020, 15:52
1
उस समय स्पंदन साफ ​​काम नहीं किया। धन्यवाद
 – 
greenycodeskii
9 पद 2020, 13:59

मैंने इसका अनुभव किया। सबसे पहले आपको यह जांचना होगा कि क्या आपने नीचे दी गई pubspec.yaml फ़ाइल पर संबंधित निर्भरताएँ जोड़ी हैं:

Web_socket केस ==>

( pubspec.yaml पर )

निर्भरता: web_socket_channel: ^1.1.0
स्पंदन: एसडीके: स्पंदन

1
Sunggu Kim 14 पद 2020, 01:56

मेरे पास बिल्कुल वही त्रुटि थी और बाद में पता चला कि मैंने अपनी पबस्पेक फ़ाइल में वेब-केवल निर्भरता आयात की थी।

मेरे मामले में।

firebase: ^5.0.0

यह केवल वेब के लिए है।

1
Aashar Wahla 25 पद 2020, 19:25

यदि आप वीएस कोड पर हैं तो टर्मिनल पर "स्पंदन साफ फिर स्पंदन चलाएं" आज़माएं

1
Tushar Kashyap 13 अप्रैल 2021, 11:03

मुझे लगा कि यह समस्या आयात 'पैकेज: फायरबेस/फायरबेस.डार्ट' के कारण हुई है; मेरी परियोजना में इसे ठीक करने के लिए उस आयात को हटा दें

0
Kirito344 18 जून 2021, 19:00

मेरे मामले में, मुझे एक ही समस्या और समाधान था:

flutter clean . 
 
flutter create .

यह एक ऐसा समाधान है जिसे मैं लगभग किसी भी समस्या से पहले हमेशा कोशिश करता हूं, फिर अगर यह हल नहीं होता है तो मैं इसे देखता हूं ..

0
Alejandro Polak 14 जुलाई 2021, 17:03

अगर आपने ऐसा आयात जोड़ा है तो करीब से देखें?

    import 'package:firebase/firebase.dart';

यदि हां, तो यह वेब के लिए है। यदि आप मोबाइल एप्लिकेशन लिख रहे हैं, तो ऐसे आयात का उपयोग करना बेहतर है:

    import 'package:firebase_auth/firebase_auth.dart';

यह एक संभावित त्रुटि हो सकती है।

0
Mc Ride 3 अगस्त 2021, 19:02