मैं अजगर का उपयोग करके GUI एप्लिकेशन को आज़माने के लिए kivy स्थापित करने का प्रयास कर रहा था, हालाँकि Visual Studio C++ 141 बिल्ड को स्थापित करने और python -m pip install kivy का उपयोग करके kivy स्थापित करने का प्रयास करने के बाद मुझे लगता है कि अजगर ने पॉप-अप काम करना बंद कर दिया है। किसी को पता है कि समस्या क्या हो सकती है? अग्रिम में धन्यवाद। यहां छवि विवरण दर्ज करें

0
Mateusz 16 मार्च 2020, 13:02

2 जवाब

सबसे बढ़िया उत्तर

नमस्ते, मैंने अभी निम्नलिखित पाया और अजगर 3.7.3 स्थापित किया और किवी स्थापित करने में सक्षम था:

पाइप पीईपीआई से खींचता है और, इस लेखन के समय, पीईपीआई पर किवी 1.11.1 में केवल पायथन 2.7 और 3.5 - 3.7 के लिए पहिए हैं।

आपके पास्टबिन आउटपुट के आधार पर, आप पाइथन 3.8 का उपयोग कर रहे हैं। इसका मतलब यह है कि पायथन अभी PyPI के किसी भी पूर्व-निर्मित पहिये का उपयोग नहीं कर सकता है। और पाइप पाइथन 3.8 के लिए किवी को स्क्रैच से संकलित करने वाले मुद्दों में चल रहा प्रतीत होता है (जो विंडोज़ पर अधिक जटिल परियोजनाओं/मॉड्यूल के लिए असामान्य नहीं है)।

एक सामान्य अनुशंसा के रूप में, आपको उदा. के वर्तमान संस्करण का उपयोग करने पर विचार करना चाहिए। Python 3.7 (उदा. Python 3.7.6) Kivy के साथ, क्योंकि इससे आपके सामने आने वाली समस्याओं का समाधान थोड़े अतिरिक्त प्रयास से होना चाहिए।

एकाधिक पायथन इंस्टॉलेशन

विंडोज़ पर, आप एक इंस्टॉलेशन के बिना दूसरे को प्रभावित किए बिना पायथन के कई संस्करण स्थापित कर सकते हैं। सामान्य इंस्टॉलेशन प्रक्रिया के माध्यम से आप जिस पायथन का उपयोग करना चाहते हैं, उसके अतिरिक्त संस्करण को बस इंस्टॉल करें (उदाहरण के लिए ऊपर दिए गए python.org से वेनिला इंस्टॉलर के साथ)।

आशा है कि यह आपकी भी मदद करता है। धन्यवाद

1
Abdur-Rasheed Ryklief 2 मई 2020, 18:39

त्वरित समाधान व्हील अपडेट की प्रतीक्षा करने के बजाय सीधे कीवी मास्टर शाखा का उपयोग करेगा।

निम्न आदेश चलाएँ:

pip install kivy[base] kivy_examples --pre --extra-index-url https://kivy.org/downloads/simple/
2
Ali Sajjad 23 अगस्त 2020, 02:57