मैं लार्वा का एक पुराना संस्करण स्थापित करने का प्रयास कर रहा हूं जो मुझे [InvalidArgumentException] Could not find package laravel/laravel with version 5.8.* in a version installable using your PHP version, PHP extensions and Composer version. देता है

यह मेरा PHP संस्करण है $ पीएचपी --संस्करण PHP 8.0.0 (cli) (built: Nov 24 2020 22:02:57) ( ZTS Visual C++ 2019 x64 ) Copyright (c) The PHP Group Zend Engine v4.0.0-dev, Copyright (c) Zend Technologies

मैंने इस कमांड का उपयोग लार्वा को स्थापित करने के लिए किया था $ composer create-project --prefer-dist laravel/laravel blog "5.8.*"

मैंने कंपोज़र इंस्टॉलेशन को हटा दिया और इसे फिर से इंस्टॉल किया यह हमेशा वही त्रुटि देता है। कोई मदद?

अग्रिम में धन्यवाद

0
Mohamed Mahfouz 31 जिंदा 2021, 10:56
आपने लारवेल को कैसे स्थापित किया? हमें संगीतकार कमांड दिखाएं
 – 
Abdulla Nilam
31 जिंदा 2021, 11:01
$ composer create-project --prefer-dist laravel/laravel blog "5.8.*"
 – 
Moh
31 जिंदा 2021, 11:02
composer -vvv about चलाएं और आउटपुट पोस्ट करें
 – 
Abdulla Nilam
31 जिंदा 2021, 11:04
यह Failed to initialize global composer: Composer could not find the config file: C:/Users/pc/AppData/Roaming/Composer/composer.json To initialize a project, please create a composer.json file as described in the https://getcomposer.org/ "Getting Started" section Running 2.0.9 (2021-01-27 16:09:27) with PHP 8.0.0 on Windows NT / 10.0 Failed to initialize global composer: Composer could not find the config file: C:/Users/pc/AppData/Roaming/Composer/composer.json To initialize a project, please create a composer.json file as described देता है
 – 
Moh
31 जिंदा 2021, 11:07
संगीतकार स्थापना के साथ समस्या। क्या आप वैंप या xampp का उपयोग कर रहे हैं ?? लार्वेल 5.* संस्करणों के साथ PHP 7.1 का उपयोग करें
 – 
Abdulla Nilam
31 जिंदा 2021, 11:11

2 जवाब

सबसे बढ़िया उत्तर

आप PHP 8.0 पर Laravel 5.8 नहीं चला सकते। लारवेल 5.8 के लिए PHP ^7.1.1.3 की आवश्यकता है। पूरी तरह से PHP 8.0 का समर्थन करने वाला एकमात्र संस्करण Laravel 8.x है।

इसके अलावा, मैं दृढ़ता से सलाह देता हूं कि इस तरह के पुराने लारवेल संस्करण का उपयोग न करें, क्योंकि यह अब सक्रिय रूप से बनाए नहीं रखा गया है। सौभाग्य से, मौजूदा Laravel 5.8 प्रोजेक्ट को Laravel 6 में अपग्रेड करना काफी सरल है, बस https:/ पर जाएं। /laravel.com/docs/6.x/upgrad और अपग्रेड गाइड के माध्यम से अपना काम करें।

लारवेल 6 एक एलटीएस संस्करण है और 7 सितंबर, 2021 तक बग फिक्स और 6 सितंबर, 2022 तक सुरक्षा सुधार प्राप्त करेगा।

Laravel ६ से ७ और ७ से ८ को अपग्रेड करना ५.८ -> ६ अपडेट की तुलना में एक समस्या से भी कम है, इसलिए हो सकता है कि आप तब तक जारी रखना चाहें जब तक आप अप टू डेट न हों और PHP 8.0 के साथ टिक सकें।

0
Lupinity Labs 31 जिंदा 2021, 11:27

Laravel 5.8 PHP 8 के साथ काम करता है, अपने PHP संस्करण को 7.4 पर डाउनग्रेड करता है और इसे काम करना चाहिए

0
Mutabor 31 जिंदा 2021, 11:13
ज़रूर, लेकिन यह उसका सवाल नहीं था कि वह लारवेल 5.8 चलाना चाहता है, शायद वह अपने ऐप को लारवेल 8 या कुछ स्वतंत्रताओं के साथ काम नहीं करता है जो जानते हैं
 – 
Mutabor
31 जिंदा 2021, 22:31