मुझे अपने निर्माण-प्रतिक्रिया-ऐप एप्लिकेशन पर प्रतिक्रिया-रेडक्स पैकेज स्थापित करने का प्रयास करने में त्रुटि हो रही है। मैंने अपने नोड_मॉड्यूल्स फ़ोल्डर को हटाने और पुनर्स्थापित करने के साथ-साथ इसे व्यवस्थापक अनुमतियों के साथ स्थापित करने का प्रयास किया है और मुझे अभी भी वही त्रुटि मिल रही है

➜  frontend git:(main) ✗ npm i react-redux
npm ERR! code ERESOLVE
npm ERR! ERESOLVE unable to resolve dependency tree

यहाँ कंसोल से शेष आउटपुट है

npm ERR! 
npm ERR! While resolving: frontend@0.1.0
npm ERR! Found: react@17.0.1
npm ERR! node_modules/react
npm ERR!   react@"^17.0.1" from the root project
npm ERR! 
npm ERR! Could not resolve dependency:
npm ERR! peer react@"^16.8.3" from react-redux@7.2.1
npm ERR! node_modules/react-redux
npm ERR!   react-redux@"*" from the root project
npm ERR! 
npm ERR! Fix the upstream dependency conflict, or retry
npm ERR! this command with --force, or --legacy-peer-deps
npm ERR! to accept an incorrect (and potentially broken) dependency resolution.

यहाँ मेरे पैकेज में वर्तमान निर्भरता की सूची है।json

 "dependencies": {
    "@testing-library/jest-dom": "^4.2.4",
    "@testing-library/react": "^9.5.0",
    "@testing-library/user-event": "^7.2.1",
    "axios": "^0.21.0",
    "react": "^17.0.1",
    "react-bootstrap": "^1.4.0",
    "react-dom": "^17.0.1",
    "react-router-bootstrap": "^0.25.0",
    "react-router-dom": "^5.2.0",
    "react-scripts": "3.4.4",
    "redux": "^4.0.5",
    "redux-devtools-extension": "^2.13.8",
    "redux-thunk": "^2.3.0",
    "tachyons": "^4.12.0"
  },
29
Moose Hamid 26 अक्टूबर 2020, 02:45

6 जवाब

सबसे बढ़िया उत्तर

ऐसा लगता है कि आप नवीनतम npm संस्करण (v7) का उपयोग कर रहे हैं। जैसा कि लॉग में उल्लेख किया गया है, इसके साथ प्रयास करें npm install --legacy-peer-deps


पिछली बार npm ब्लॉग ने --legacy-peer-deps ध्वज का उल्लेख किया था, जबकि npm v7 का उनका बीटा संस्करण सार्वजनिक हुआ था। फ़्लैग के बारे में अधिक पढ़ने के लिए यहां जाएं< /ए>.

65
Community 2 नवम्बर 2020, 19:06
एक और एनपीएम पैकेज स्थापित करने की कोशिश कर रहा है और इसी तरह की त्रुटियां मिली हैं। विकल्प --legacy-peer-deps के साथ इंस्टॉल करने से समस्याएं हल हो गईं।
 – 
Caco
14 जून 2021, 20:23

अनुशंसित नोडज संस्करण स्थापित करने का प्रयास करें (नीचे स्क्रीन शॉट)। जो इस मुद्दे को ठीक करना चाहिए।

enter image description here

यहाँ इस त्रुटि और उसके समाधान का मनोरंजन है (नीचे स्क्रीनशॉट):

समस्या:

नोडज: नवीनतम सुविधाएं:

enter image description here

समाधान:

Nodejs : अधिकांश उपयोगकर्ताओं के लिए अनुशंसित:

enter image description here

नोड जेएस के अनुशंसित संस्करण को स्थापित करने से इस मुद्दे को तुरंत प्रासंगिक निर्भरता की स्थापना की अनुमति मिलती है।

यदि आप प्रतिक्रिया-मूल निर्भरता के साथ इस समस्या का सामना कर रहे हैं तो एक बार अनुशंसित संस्करण स्थापित करने के बाद अपनी पॉड फ़ाइल को अपडेट करना सुनिश्चित करें।

13
A Shirazee 1 फरवरी 2021, 10:57

Node.js नवीनतम "अधिकांश उपयोगकर्ताओं के लिए अनुशंसित" संस्करण का उपयोग करने का प्रयास करें। यह मेरे लिए काम किया

4
Masoud Mohajeri 30 जिंदा 2021, 21:21

दो तरीके:

  1. npm install <package-name> --legacy-peer-deps
  2. अधिकांश उपयोगकर्ताओं के लिए अनुशंसित नोड संस्करण स्थापित करें

सभी पैकेजों के लिए काम करने के लिए नोड के अनुशंसित संस्करण को स्थापित करने का बेहतर तरीका है।

3
ZygD 28 जून 2021, 13:40

मैक के लिए कोशिश की, यह काम किया .. नवीनतम एलटीएस में अपग्रेड करने के लिए चरणों का पालन करें

  1. Node.js रिलीज़ को अपडेट करने से पहले, जांचें कि आप वर्तमान में किस संस्करण के साथ उपयोग कर रहे हैं: नोड -v

  2. अगला, कमांड के साथ npm कैश साफ़ करें: npm कैश क्लीन -f

  3. विश्व स्तर पर n स्थापित करें: एनपीएम इंस्टॉल -जी एन

  4. अब जब आपने n इंस्टॉल कर लिया है, तो आप Node.js की नवीनतम स्थिर रिलीज़ को स्थापित करने के लिए मॉड्यूल का उपयोग कर सकते हैं: सुडो एन स्थिर

वैकल्पिक रूप से, आप नवीनतम सुविधाओं के साथ Node.js रिलीज़ स्थापित कर सकते हैं:

सुडो एन नवीनतम

या, इसके साथ एक विशिष्ट संस्करण संख्या स्थापित करें: n [संस्करण। संख्या]

2
rsb 26 फरवरी 2021, 06:28

इसे यार्न के साथ जोड़ने का प्रयास करें। मेरे लिए काम किया

-3
drunkenmaster 15 मार्च 2021, 22:27
धन्यवाद, npm install -g yarn के माध्यम से यार्न स्थापित करने के बाद मेरे लिए काम किया
 – 
Hassan Jamil
10 अक्टूबर 2021, 08:37