कृपया मदद करें, मैंने अभी कुछ विकास कार्यों के लिए भुगतान किया है और ऐप को वापस ले लिया है। डेवलपर का दावा है कि उन्हें ऐप चलाने में कोई समस्या नहीं है। मैं इसे अपनी मशीन पर चलाने के लिए नहीं मिल सकता। ऐप डेवलपर द्वारा ब्लॉक के माध्यम से राज्य प्रबंधन को जोड़ने से पहले चल रहा था।

यह पैकेज/कोकोपोड्स/एक्सकोड त्रुटि जैसा दिखता है जिसे नवीनतम संस्करणों का उपयोग करके हल किया जाना चाहिए, लेकिन मैं कुछ भी नहीं कर सकता इन त्रुटियों को साफ़ करता हूं। हर बार जब मैं करीब आता हूं तो मैं फिर से दौड़ता हूं और सभी त्रुटियां वापस आ जाती हैं। मैं संकल्प के बिना एक अंतहीन समस्या निवारण पाश में हूँ। मैं एक नौसिखिया हूं और समस्या निवारण के लिए डेवलपर को $50hr का भुगतान करने का जोखिम नहीं उठा सकता है कि मेरे कंप्यूटर पर कोई ऐप क्यों नहीं चलेगा इसलिए मैं उपकरण नीचे हूं और जब तक मैं इस समस्या को हल नहीं कर लेता तब तक रुका हुआ हूं।

मैंने Cocoapods को फिर से स्थापित किया है। मैंने PODS फ़ाइल को हटाने का प्रयास किया है। मैंने एक पुरानी PODS फ़ाइल का उपयोग करने का प्रयास किया है। मैंने सुनिश्चित किया है कि यह ffi आर्क इंस्टाल के साथ M1 के लिए सही संस्करण है। मैंने अपना डेवलपर प्रमाणपत्र अपडेट कर लिया है। आर्क 86 को एक्सकोड सेटिंग्स में चिपकाया। परिनियोजन के लिए संस्करणों को नवीनतम पर सेट करें। मैंने अपने मैक को पूरी तरह से मिटा दिया है और सभी वातावरणों को खरोंच से पुनर्स्थापित कर दिया है लेकिन त्रुटियां बनी रहती हैं। मैंने स्पंदन साफ ​​किया है और स्पंदन पब मिलता है और स्पंदन आईओएस का निर्माण करता है और पिछले सप्ताह में 1000 बार स्पंदन चलता है। मुझे आईओएस के लिए यह ऐप नहीं मिल रहा है और मैं अपना दिमाग खो रहा हूं। मैं इसे लगभग 2 सप्ताह से चलाने की कोशिश कर रहा हूँ! डेवलपर ने मेरे साथ एक घंटा बिताया और उन्होंने मुझसे केवल वही करने को कहा जो मैंने पहले ही ज्ञात मुद्दों के लिए ऑनलाइन खोज कर किया था। मुझे कोई विचार नहीं सूझ रहा। मुझे इसे हल करने में मदद चाहिए। कृपया सहायता कीजिए

Error output from Xcode build:
↳
    objc[19329]: Class AMSupportURLConnectionDelegate is implemented in both /usr/lib/libauthinstall.dylib (0x20c172c10) and
    /System/Library/PrivateFrameworks/MobileDevice.framework/Versions/A/MobileDevice (0x1141502b8). One of the two will be used. Which one is undefined.
    objc[19329]: Class AMSupportURLSession is implemented in both /usr/lib/libauthinstall.dylib (0x20c172c60) and
    /System/Library/PrivateFrameworks/MobileDevice.framework/Versions/A/MobileDevice (0x114150308). One of the two will be used. Which one is undefined.
    2021-07-22 22:34:26.062 xcodebuild[19329:246509] CFURLRequestSetHTTPCookieStorageAcceptPolicy_block_invoke: no longer implemented and should not be called
    ** BUILD FAILED **


Xcode's output:
↳
    /Users/tlcf/Development/flutter/.pub-cache/hosted/pub.dartlang.org/location-4.3.0/ios/Classes/LocationPlugin.m:176:13: warning: 'UIAlertView' is deprecated:
    first deprecated in iOS 9.0 - UIAlertView is deprecated. Use UIAlertController with a preferredStyle of UIAlertControllerStyleAlert instead
    [-Wdeprecated-declarations]
                UIAlertView *alert = [[UIAlertView alloc] initWithTitle:@"Location is Disabled"
                ^
    In module 'UIKit' imported from /Users/tlcf/Development/simposi-main/ios/Pods/Target Support Files/location/location-prefix.pch:2:
    /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS14.5.sdk/System/Library/Frameworks/UIKit.framework/Headers/UIAler
    tView.h:27:12: note: 'UIAlertView' has been explicitly marked deprecated here
    @interface UIAlertView : UIView
               ^
    /Users/tlcf/Development/flutter/.pub-cache/hosted/pub.dartlang.org/location-4.3.0/ios/Classes/LocationPlugin.m:176:48: warning: 'UIAlertView' is deprecated:
    first deprecated in iOS 9.0 - UIAlertView is deprecated. Use UIAlertController with a preferredStyle of UIAlertControllerStyleAlert instead
    [-Wdeprecated-declarations]
                UIAlertView *alert = [[UIAlertView alloc] initWithTitle:@"Location is Disabled"
                                                   ^
    In module 'UIKit' imported from /Users/tlcf/Development/simposi-main/ios/Pods/Target Support Files/location/location-prefix.pch:2:
    /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS14.5.sdk/System/Library/Frameworks/UIKit.framework/Headers/UIAler
    tView.h:27:12: note: 'UIAlertView' has been explicitly marked deprecated here
    @interface UIAlertView : UIView
               ^
    2 warnings generated.
    /Users/tlcf/Development/flutter/.pub-cache/hosted/pub.dartlang.org/location-4.3.0/ios/Classes/LocationPlugin.m:176:13: warning: 'UIAlertView' is deprecated:
    first deprecated in iOS 9.0 - UIAlertView is deprecated. Use UIAlertController with a preferredStyle of UIAlertControllerStyleAlert instead
    [-Wdeprecated-declarations]
                UIAlertView *alert = [[UIAlertView alloc] initWithTitle:@"Location is Disabled"
                ^
    In module 'UIKit' imported from /Users/tlcf/Development/simposi-main/ios/Pods/Target Support Files/location/location-prefix.pch:2:
    /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS14.5.sdk/System/Library/Frameworks/UIKit.framework/Headers/UIAler
    tView.h:27:12: note: 'UIAlertView' has been explicitly marked deprecated here
    @interface UIAlertView : UIView
               ^
    /Users/tlcf/Development/flutter/.pub-cache/hosted/pub.dartlang.org/location-4.3.0/ios/Classes/LocationPlugin.m:176:48: warning: 'UIAlertView' is deprecated:
    first deprecated in iOS 9.0 - UIAlertView is deprecated. Use UIAlertController with a preferredStyle of UIAlertControllerStyleAlert instead
    [-Wdeprecated-declarations]
                UIAlertView *alert = [[UIAlertView alloc] initWithTitle:@"Location is Disabled"
                                                   ^
    In module 'UIKit' imported from /Users/tlcf/Development/simposi-main/ios/Pods/Target Support Files/location/location-prefix.pch:2:
    /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS14.5.sdk/System/Library/Frameworks/UIKit.framework/Headers/UIAler
    tView.h:27:12: note: 'UIAlertView' has been explicitly marked deprecated here
    @interface UIAlertView : UIView
               ^
    2 warnings generated.
    /Users/tlcf/Development/flutter/.pub-cache/hosted/pub.dartlang.org/geolocator-7.3.0/ios/Classes/GeolocatorPlugin.m:156:55: error: expected expression
                        openURL:options:completionHandler::[NSURL URLWithString:UIApplicationOpenSettingsURLString]];
                                                          ^
    /Users/tlcf/Development/flutter/.pub-cache/hosted/pub.dartlang.org/geolocator-7.3.0/ios/Classes/GeolocatorPlugin.m:156:29: error: use of undeclared identifier
    'options'
                        openURL:options:completionHandler::[NSURL URLWithString:UIApplicationOpenSettingsURLString]];
                                ^
    /Users/tlcf/Development/flutter/.pub-cache/hosted/pub.dartlang.org/geolocator-7.3.0/ios/Classes/GeolocatorPlugin.m:156:37: error: use of undeclared identifier
    'completionHandler'
                        openURL:options:completionHandler::[NSURL URLWithString:UIApplicationOpenSettingsURLString]];
                                        ^
    3 errors generated.
    note: Using new build system
    note: Building targets in parallel
    note: Planning build
    note: Analyzing workspace
    note: Constructing build description
    note: Build preparation complete
    /Users/tlcf/Development/simposi-main/ios/Pods/Pods.xcodeproj: warning: The iOS deployment target 'IPHONEOS_DEPLOYMENT_TARGET' is set to 8.0, but the range of
    supported deployment target versions is 9.0 to 14.5.99. (in target 'Flutter' from project 'Pods')


It appears that your application still contains the default signing identifier.
Try replacing 'com.example' with your signing id in Xcode:
  open ios/Runner.xcworkspace
Encountered error while building for device.
2
BigPictureDeepDive 23 जुलाई 2021, 08:54

2 जवाब

सबसे बढ़िया उत्तर

इसे सुलझा लिया। डेवलपर्स को काम पर रखने से पहले मैं अपने पिछले वर्किंग वर्जन पर वापस गया और यह ठीक चलता है। तो मैंने उनके lib को चिपकाया ... और वह त्रुटिपूर्ण। उन्होंने त्रुटि को देखा और ऐसा इसलिए था क्योंकि मुझे intl फ़ाइल में पेस्ट करने और फिर Xcode में कुछ सेटिंग्स को ठीक करने की आवश्यकता थी। हम में से कोई नहीं जानता कि यह केवल मेरे कंप्यूटर पर क्यों त्रुटि कर रहा था या मेरी आखिरी कामकाजी प्रति में अपना काम क्यों चिपका रहा था, लेकिन यह हल हो गया है। मुझे संदेह है कि एक्सकोड के नवीनतम अपडेट के कारण यह एक गिट संघर्ष था, लेकिन हम वास्तव में नहीं जानते कि क्यों। लेकिन इसका समाधान हो गया है।

उन लोगों के लिए धन्यवाद जिन्होंने मदद करने की कोशिश की।

0
BigPictureDeepDive 27 जुलाई 2021, 06:55

खैर यह स्पष्ट है कि क्या हो रहा है - त्रुटि पढ़ें: 'IPHONEOS_DEPLOYMENT_TARGET' 8.0 पर सेट है, लेकिन समर्थित परिनियोजन लक्ष्य संस्करणों की सीमा 9.0 से 14.5.99 है।

इसे अपनी पॉड फ़ाइल में जोड़ें / बदलें

post_install do |installer|
  installer.pods_project.targets.each do |target|
    flutter_additional_ios_build_settings(target)
    target.build_configurations.each do |config|
      config.build_settings['IPHONEOS_DEPLOYMENT_TARGET'] = '9.0'
    end
  end
end

साथ ही आपने इस प्रोजेक्ट पर अपने खाते से साइन इन नहीं किया

S.Shot Xcode Signing & Capabilities

आपको संभवतः प्रत्येक पॉड लक्ष्य को मैन्युअल रूप से 9.0 . पर सेट करने की आवश्यकता होगी

0
Aristidios 23 जुलाई 2021, 09:23