मैं अभी भी php लार्वा के लिए नया हूँ, इसलिए आपकी मदद की वास्तव में सराहना की जाएगी

Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Conclusion: don't install laravel/framework v5.7.9
    - Conclusion: remove laravel/framework v5.7.8
    - Conclusion: don't install laravel/framework v5.7.8
    - Conclusion: don't install laravel/framework v5.7.7
    - Conclusion: don't install laravel/framework v5.7.6
    - Conclusion: don't install laravel/framework v5.7.5
    - Conclusion: don't install laravel/framework v5.7.4
    - Conclusion: don't install laravel/framework v5.7.3
    - Conclusion: don't install laravel/framework v5.7.2
    - Conclusion: don't install laravel/framework v5.7.1
    - Conclusion: don't install laravel/framework v5.7.0
    - laravelcollective/html 5.4.x-dev requires illuminate/view 5.4.* -> satisfiable by illuminate/view[5.4.x-dev, v5.4.0, v5.4.13, v5.4.17, v5.4.19, v5.4.27, v5.4.36, v5.4.9].
    - laravelcollective/html v5.4 requires illuminate/view 5.4.* -> satisfiable by illuminate/view[5.4.x-dev, v5.4.0, v5.4.13, v5.4.17, v5.4.19, v5.4.27, v5.4.36, v5.4.9].
    - laravelcollective/html v5.4.1 requires illuminate/view 5.4.* -> satisfiable by illuminate/view[5.4.x-dev, v5.4.0, v5.4.13, v5.4.17, v5.4.19, v5.4.27, v5.4.36, v5.4.9].
    - laravelcollective/html v5.4.2 requires illuminate/view 5.4.* -> satisfiable by illuminate/view[5.4.x-dev, v5.4.0, v5.4.13, v5.4.17, v5.4.19, v5.4.27, v5.4.36, v5.4.9].
    - laravelcollective/html v5.4.3 requires illuminate/view 5.4.* -> satisfiable by illuminate/view[5.4.x-dev, v5.4.0, v5.4.13, v5.4.17, v5.4.19, v5.4.27, v5.4.36, v5.4.9].
    - laravelcollective/html v5.4.4 requires illuminate/view 5.4.* -> satisfiable by illuminate/view[5.4.x-dev, v5.4.0, v5.4.13, v5.4.17, v5.4.19, v5.4.27, v5.4.36, v5.4.9].
    - laravelcollective/html v5.4.5 requires illuminate/view 5.4.* -> satisfiable by illuminate/view[5.4.x-dev, v5.4.0, v5.4.13, v5.4.17, v5.4.19, v5.4.27, v5.4.36, v5.4.9].
    - laravelcollective/html v5.4.6 requires illuminate/view 5.4.* -> satisfiable by illuminate/view[5.4.x-dev, v5.4.0, v5.4.13, v5.4.17, v5.4.19, v5.4.27, v5.4.36, v5.4.9].
    - laravelcollective/html v5.4.7 requires illuminate/view 5.4.* -> satisfiable by illuminate/view[5.4.x-dev, v5.4.0, v5.4.13, v5.4.17, v5.4.19, v5.4.27, v5.4.36, v5.4.9].
    - laravelcollective/html v5.4.8 requires illuminate/view 5.4.* -> satisfiable by illuminate/view[5.4.x-dev, v5.4.0, v5.4.13, v5.4.17, v5.4.19, v5.4.27, v5.4.36, v5.4.9].
    - laravelcollective/html v5.4.9 requires illuminate/view 5.4.* -> satisfiable by illuminate/view[5.4.x-dev, v5.4.0, v5.4.13, v5.4.17, v5.4.19, v5.4.27, v5.4.36, v5.4.9].
    - don't install illuminate/view 5.4.x-dev|don't install laravel/framework 5.7.x-dev
    - don't install illuminate/view v5.4.0|don't install laravel/framework 5.7.x-dev
    - don't install illuminate/view v5.4.13|don't install laravel/framework 5.7.x-dev
    - don't install illuminate/view v5.4.17|don't install laravel/framework 5.7.x-dev
    - don't install illuminate/view v5.4.19|don't install laravel/framework 5.7.x-dev
    - don't install illuminate/view v5.4.27|don't install laravel/framework 5.7.x-dev
    - don't install illuminate/view v5.4.36|don't install laravel/framework 5.7.x-dev
    - don't install illuminate/view v5.4.9|don't install laravel/framework 5.7.x-dev
    - Installation request for laravel/framework 5.7.* -> satisfiable by laravel/framework[5.7.x-dev, v5.7.0, v5.7.1, v5.7.2, v5.7.3, v5.7.4, v5.7.5, v5.7.6, v5.7.7, v5.7.8, v5.7.9].
    - Installation request for laravelcollective/html 5.4.* -> satisfiable by laravelcollective/html[5.4.x-dev, v5.4, v5.4.1, v5.4.2, v5.4.3, v5.4.4, v5.4.5, v5.4.6, v5.4.7, v5.4.8, v5.4.9].

मैं वास्तव में अपनी PHP फ़ाइल चलाने की कोशिश कर रहा हूं, लेकिन यह दिखाता है

कक्षा 'सामूहिक\Html\HtmlServiceProvider' नहीं मिला

इसलिए मैंने इंटरनेट के माध्यम से खोज की और उन्होंने कहा कि मुझे अपडेट करने की आवश्यकता है, जब मैंने इसे अपडेट करने का प्रयास किया, तो क्या किसी को पता है कि मुझे क्या करना है?

साथ ही मैंने config/app.php . में जोड़ा

Inside Providers

Collective\Html\HtmlServiceProvider::class,
Inside aliases

'Form' => Collective\Html\FormFacade::class,
'Html' => Collective\Html\HtmlFacade::class,

आशा है कि कोई मदद कर सकता है

-1
Muhd Iqbal 10 अक्टूबर 2018, 13:08

1 उत्तर

सबसे बढ़िया उत्तर

ऐसा इसलिए हो रहा है क्योंकि आपकी कंपोज़र.जेसन फ़ाइल में laravelcollection/html संस्करण 5.4 के साथ पैकेज है जो Laravel 5.4 के साथ संगत है लेकिन आप Laravel 5.7 का उपयोग कर रहे हैं, मैं आपको सलाह दूंगा कि आप कोशिश करें और अपनी जांच करें composer.json और उस लाइन को अपडेट करें जहां आप उस पैकेज को इसमें जोड़ रहे हैं:

"laravelcollective/html":"^5.4.0",

ऐसा करने के बाद मैं आपको composer update करने की सलाह दूंगा, अगर यह विफल हो जाता है, तो आपको ऊपर दिए गए इस पैकेज को हटाना होगा, क्योंकि यह नवीनतम Laravel संस्करण के साथ संगत नहीं है, या आप निश्चित रूप से Laravel को कम कर सकते हैं। Laravel संस्करण, जो कुछ भी आपके आवेदन के साथ ठीक है, की जरूरत है।

साथ ही, प्रत्येक illuminate/* पैकेज वास्तव में Laravel core code है, वे बेस पैकेज हैं जिनसे लार्वा बना है।

2
Nikola Gavric 10 अक्टूबर 2018, 13:13