मैं WAMP सर्वर PHP संस्करण 7.2 के साथ स्थानीय सिस्टम पर एक मौजूदा Magento प्रोजेक्ट को कॉन्फ़िगर कर रहा हूं, जबकि Magento स्थापित करते समय मुझे त्रुटि मिलती है "PHP एक्सटेंशन" mcrypt "लोड होना चाहिए।" समस्या यह है कि mycrypt अब PHP 7.2 में समर्थित नहीं है, क्या कोई सुझाव दे सकता है कि मैं इसे कैसे हल कर सकता हूं?

2
Vikky 28 सितंबर 2018, 09:48

1 उत्तर

सबसे बढ़िया उत्तर

Mcrypt को 7.2 के बाद से php से pecl में स्थानांतरित कर दिया गया है

आप अभी भी इसे स्थापित कर सकते हैं।

निर्भरता स्थापित करें

gcc make autoconf libc-dev pkg-config

लिब ही स्थापित करें

libmcrypt-dev

मुझे लगता है कि php7.2 और pecl स्थापित हैं, इसलिए आप बस pecl के साथ mcrypt-1.0.1 (या जो भी संस्करण प्रतिनिधि में है) स्थापित करें।

pecl install mcrypt-1.0.1
3
Vladimir Samsonov 28 सितंबर 2018, 11:09