मैं वर्चुअल सर्वर चला रहा हूं:

  • वर्चुअलबॉक्स v5.2.12
  • उबंटू v18.04
  • अपाचे v2.4.29
  • पीएचपी 7.1.17
  • मैगेंटो v२.२.४

जब तक मैं Magento स्थापित नहीं करता तब तक सब कुछ ठीक हो जाता है! Magento सर्वर में किसी भी समस्या के बिना काम करता है लेकिन यहाँ समस्या तब है जब मैंने mywebsite.com में प्रवेश किया यह मेरी फ़ाइलें और अनुक्रमण दिखाता है और मैं इसके बजाय अपना index.html दिखाना चाहता हूं:

Index of /
Name    Last modified   Size    Description
index.html  2018-05-28 03:47    180      
info.php    2018-06-04 12:39    20   
magento2/   2018-05-01 23:21    -    
Apache/2.4.29 (Ubuntu) Server at mywebsite.com Port 65533

मैंने बहुत जवाब देने की कोशिश की लेकिन कोई सफलता नहीं मिली।

यहाँ है /etc/apache2/apache2.conf

<Directory />
    Options FollowSymLinks
    AllowOverride None
    Require all denied
</Directory>

<Directory /usr/share>
    AllowOverride None
    Require all granted
</Directory>

<Directory /var/www>
    Options Indexes FollowSymLinks
    AllowOverride None
    Require all granted
</Directory>

और यहाँ है /etc/apache2/sites-available/mywebsite.com.conf

Listen 65533
    <VirtualHost mywebsite.com:65533>

    ServerName www.mywebsite.com
    ServerName mywebsite.com

    ServerAdmin info@mywebsite.info
    ServerName mywebsite.com
    ServerAlias www.mywebsite.com
    DocumentRoot /var/www/mywebsite.com/html

    ErrorLog ${APACHE_LOG_DIR}/error.log
    CustomLog ${APACHE_LOG_DIR}/access.log combined

    <Directory />

        Options FollowSymLinks

        AllowOverride None

    </Directory>

    <Directory /var/www/mywebsite.com/html/>

        Options Indexes FollowSymLinks Multiviews

        AllowOverride All

        Require all granted

     </Directory>

</VirtualHost>

यहाँ है /etc/apache2/sites-available/000-default.conf.conf

<VirtualHost *:80>

    ServerAdmin webmaster@localhost
    DocumentRoot /var/www/html

    ErrorLog ${APACHE_LOG_DIR}/error.log
    CustomLog ${APACHE_LOG_DIR}/access.log combined

</VirtualHost>
0
qlf 5 जून 2018, 22:21

1 उत्तर

सबसे बढ़िया उत्तर

अंत में मैंने इस मुद्दे को हल कर दिया .. एक हफ्ते से कोशिश कर रहा था!

समाधान है: चरण 1- इस फ़ाइल के अंदर "/etc/apache2/sites-available/mywebsite.com.conf" यह वर्चुअलहोस्ट जानकारी के बाद पहली निर्देशिका स्ट्रेट होनी चाहिए:

<Directory />
            Options FollowSymLinks
            AllowOverride None
</Directory>

और यह पूरी फाइल को प्रभावित करेगा .. ठीक है अब तक बहुत अच्छा।

चरण 2- मैंने विशेष रूप से magento के लिए एक नई निर्देशिका जोड़ी है जो है

<Directory /var/www/mywebsite.com/html/magento2>
           Options Indexes FollowSymLinks Multiviews
           AllowOverride All
           Require all granted
</Directory>

चरण 3- sudo /etc/init.d/apache2 restart स्थिति के साथ अपाचे को पुनरारंभ करने के लिए या पुनरारंभ करने के लिए किसी भी विधि का उपयोग करें।

** यहाँ बिंदु यह है कि आपको प्रत्येक निर्देशिका के साथ अलग से काम करने के लिए निर्देशिका वंशानुक्रम / सभी के लिए एक सेटिंग से बचने की आवश्यकता है।

आशा है किसी को इस पोस्ट से लाभ मिलेगा।

थोड़ी सी मदद के लिए धन्यवाद एंड्रा।

सादर, क्यूएलएफ

0
qlf 6 जून 2018, 01:39