मैं मैक ओएस मोजावे का उपयोग कर रहा हूं, अजगर 2.7 स्थापित करें और python get-pip.py का उपयोग करके पाइप स्थापित करें, मैं पहले से ही उन कमांड को पाइप स्थापित करने की कोशिश करता हूं:

pip install --upgrade pip
pip install nltk

और कोशिश

sudo python -m pip install --upgrade nltk

लेकिन इस छवि जैसी त्रुटि का परिणाम भी होता है

या यहाँ पाठ में:

nltk सेटअप कमांड में त्रुटि: 'install_requires' एक स्ट्रिंग या स्ट्रिंग की सूची होनी चाहिए जिसमें वैध प्रोजेक्ट/संस्करण आवश्यकता विनिर्देशक हों; सिंगलडिस्पैच में अपेक्षित संस्करण कल्पना; python_version <"3.4" पर; पायथन_वर्जन <"3.4"

क्या ऐसा इसलिए है क्योंकि मेरा पायथन संस्करण (2.7) है? लेकिन पीआईपी एनटीएलके पेज में यह भी 2.7 का समर्थन करता है

अपडेट करें:

pip install nltk दौड़ने के बाद सफलता :

pip install --upgrade setuptools pip --user
0
kafinsalim 2 नवम्बर 2019, 11:07

1 उत्तर

सबसे बढ़िया उत्तर

इंस्टॉलेशन टूल को अपग्रेड करके शुरू करें:

pip install --upgrade setuptools pip
0
phd 2 नवम्बर 2019, 12:46