मैं नियमित रूप से उन कक्षाओं में विषय मॉडलिंग के लिए MALLET का उपयोग करता हूं जिन्हें मैं पढ़ाता हूं। MALLET चलाने के लिए उपयोगकर्ताओं को जावा डेवलपमेंट किट स्थापित करने की आवश्यकता होती है। मेरे पास वर्तमान में मेरे मुख्य कंप्यूटर पर JDK 8 अपडेट 241 स्थापित है, और मुझे पता है कि MALLET इस वातावरण में ठीक से काम करता है। उस ने कहा, JDK अब v14.

JDK का कौन सा संस्करण MALLET का समर्थन करता है?

0
Brian Croxall 24 मार्च 2020, 22:32

1 उत्तर

सबसे बढ़िया उत्तर

मुझे पूरा यकीन नहीं है कि आपको जेडीके की जरूरत है। वे वेबसाइट पर ऐसा कभी नहीं कहते। टैरफाइल जिसे मैंने डाउनलोड किया है में पहले से ही संकलित कक्षाएं शामिल हैं - आपसे इसे बनाने की उम्मीद नहीं है स्रोत से - तो जेआरई पर्याप्त होना चाहिए।

अजीब तरह से, class निर्देशिका में संकलित कक्षाएं 1.7 (बाइटकोड संस्करण 51) पर लक्षित हैं जबकि पोम इंगित करता है कि यह जावा 1.6 को लक्षित करना है। तो यह काफी संभावना है कि इसे पुनर्निर्माण करके आप जावा के पुराने संस्करण का समर्थन कर सकते हैं।

किसी भी स्थिति में, JDK डिज़ाइन द्वारा पीछे की ओर संगत है। 7 के बाद से कोई भी संस्करण इसे चलाने में सक्षम होगा (6+ यदि आप इसे फिर से बनाना चाहते हैं)।

इसे नए संस्करण पर चलाने से JDK की नई सुविधाओं से लाभ होगा, जैसे कि कचरा संग्रहकर्ता में सुधार, इसलिए आप वहां कुछ प्रदर्शन सुधार देख सकते हैं। अगर आप इसके बारे में चिंतित नहीं हैं तो कोई बात नहीं।

3
Michael 24 मार्च 2020, 20:09