एक्सप्रेस-हैंडलबार स्थापित करने और "एनपीएम ऑडिट" चलाने के बाद, मुझे न्यूनतम के लिए "कम गंभीरता भेद्यता" चेतावनी मिल रही है। एनपीएम कहता है: "पैच इन> = 0.2.1 <1.0.0 ||> = 1.2.3"

https://npmjs.com/advisories/1179

इसलिए मैंने न्यूनतम v1.2.5 में अपग्रेड किया लेकिन मुझे अभी भी सुरक्षा चेतावनी मिल रही है।

  • विंडोज 10 प्रो
  • नोड: v13.11.0
  • एनपीएम: v6.14.3
  • एक्सप्रेस: ​​v4.17.1
  • एक्सप्रेस-हैंडलबार: v4.7.3
  • न्यूनतम: v1.2.5
1
mike 23 मार्च 2020, 23:06

1 उत्तर

 "@jimp/core": {
      "version": "0.8.5",
      "resolved": "https://registry.npmjs.org/@jimp/core/-/core-0.8.5.tgz",
      "integrity": "sha512-Jto1IdL5HYg7uE15rpQjK6dfZJ6d6gRjUsVCPW50nIfXgWizaTibFEov90W9Bj+irwKrX2ntG3e3pZUyOC0COg==",
      "requires": {
        "@jimp/utils": "^0.8.5",
        "any-base": "^1.1.0",
        "buffer": "^5.2.0",
        "core-js": "^2.5.7",
        "exif-parser": "^0.1.12",
        "file-type": "^9.0.0",
        "load-bmfont": "^1.3.1",
        "mkdirp": "0.5.1",
        "phin": "^2.9.1",
        "pixelmatch": "^4.0.2",
        "tinycolor2": "^1.4.1"
      },
      "dependencies": {
        "file-type": {
          "version": "9.0.0",
          "resolved": "https://registry.npmjs.org/file-type/-/file-type-9.0.0.tgz",
          "integrity": "sha512-Qe/5NJrgIOlwijpq3B7BEpzPFcgzggOTagZmkXQY4LA6bsXKTUstK7Wp12lEJ/mLKTpvIZxmIuRcLYWT6ov9lw=="
        },
        "mkdirp": {
          "version": "0.5.1",
          "resolved": "https://registry.npmjs.org/mkdirp/-/mkdirp-0.5.1.tgz",
          "integrity": "sha1-MAV0OOrGz3+MR2fzhkjWaX11yQM=",
          "requires": {
            "minimist": "^0.0.8"
          },
          "dependencies": {
            "minimist": {
              "version": "^0.0.8",
              "resolved": "https://registry.npmjs.org/minimist/-/minimist-0.0.8.tgz",
              "integrity": "sha1-hX/Kv8M5fSYluCKCYuhqp6ARsF0="
            }
          }
        }

मिनिमिस्ट को npm में अपग्रेड करें और नीचे दिए गए चरणों का पालन करें

स्निपेट के ऊपर न चलाएं

हाइलाइट की गई इमेज @ https://i.stack.imgur.com/0B0bq.png

मैंने अपने पैकेज-लॉक.जेसन फ़ाइल पर सभी मिनिमिस्ट के माध्यम से जाने के दौरान मेरा हल किया

मेरे अपने मामले में mkdir को मिनिमिस्ट की आवश्यकता थी।

मिनिमिस्ट को नीचा दिखाया गया था और इसकी आवश्यकता है, इसलिए मैंने मिनिमिस्ट के संस्करण में "^" (जैसा कि संलग्न कोड में दर्शाया गया है) को मिनिमिस्ट की आवश्यकता वाली दोनों फाइलों के लिए जोड़ा। फिर मिनिमिस्ट की आवश्यकता वाली निर्भरता मिनिमिस्ट के 0.0.8 संस्करण के अलावा मिनिमिस्ट के नवीनतम संस्करण के लिए जा सकती है

0
Adedeji Yusuf 11 पद 2020, 02:33