मेरा उपाय है

  1. मैंने अजगर 3.4.3 32 बिट संस्करण स्थापित किया है, यह पीआईपी संस्करण 6.0.8 के साथ आता है
  2. मैं अपने पाइप को इसके साथ अपग्रेड करना चाहता था: python -m pip install --upgrade pip और इसने पाइप नवीनतम संस्करण 20.0.2 . स्थापित किया
  3. मैंने इस लिंक से कुछ पहिये opencv-python डाउनलोड किए हैं https://www। lfd.uci.edu/~gohlke/pythonlibs/#opencv। मेरे मामले में मैंने opencv_python‑3.1.0‑cp34‑cp34m‑win32.whl इस व्हील फ़ाइल को डाउनलोड किया

  4. जब मैं अपग्रेड किए गए पाइप का उपयोग करके डाउनलोड किए गए व्हील को स्थापित करता हूं। मुझे इसके बारे में त्रुटि मिली: PIP को अजगर संस्करण 3.6 या उच्चतर की आवश्यकता है

ऐसा लगता है कि पीआईपी संस्करण 20.0.2 अजगर 3.4 के साथ काम नहीं करता है तो अजगर 3.4 के लिए संगत संस्करण कौन सा है?

1
Jaha 8 अप्रैल 2020, 06:17

1 उत्तर

सबसे बढ़िया उत्तर

pip के changelog पर एक नज़र डालें:

19.2 (2019-07-22)

बहिष्करण और निष्कासन

ईओएल पायथन 3.4 के लिए समर्थन छोड़ें। (#6685)

पायथन 3.4 का समर्थन करने वाला अंतिम संस्करण इस प्रकार 19.1.1 है।

5
hoefling 8 अप्रैल 2020, 10:33