एनजी बिल्ड बनाते समय मुझे बिटबकेट में यह त्रुटि मिल रही है। मैं अपने बैकएंड के रूप में फायरबेस का उपयोग कर रहा हूं। मैं क्या गलत कर रहा हूं?

EPERM: ऑपरेशन की अनुमति नहीं है, lchown '/opt/atlassian/pipelines/agent/build/node_modules/.cache/angular-build-dl/tmp' त्रुटि: EPERM: ऑपरेशन की अनुमति नहीं है, lchown '/opt/atlassian/pipelines/agent /build/node_modules/.cache/angular-build-dl/tmp'

यह बिटबकेट छवि में मेरी बिल्ड त्रुटि है यह मेरी पाइपलाइन है

'''
 - npm i @types/jquery
      - ng build
      - npm install -g firebase-tools
      - firebase deploy --only hosting --token=$FIREBASE_TOKEN --project <projrct name> --non-interactive -m "deploying the development version" 

'''
0
Vikash Kumar 25 मार्च 2020, 16:45

1 उत्तर

सबसे बढ़िया उत्तर

रूट उपयोगकर्ता को कुछ इस तरह का आकलन करने के लिए yaml फ़ाइल को बदलें।

image:
  name: imageName
  run-as-user: 0
0
Fenas S 25 मार्च 2020, 19:32