मैं कमांड चलाता हूं ng update

We analyzed your package.json, there are some packages to update:

  Name                                  Version                  Command to update
 -----------------------------------------------------------------------------------
  @angular/core                         9.0.7 -> 9.1.0           ng update @angular/core

इसलिए मैं ng update @angular/core चलाता हूं और यह कहता है Package '@angular/core' is already up to date. मैं इस मुद्दे को कैसे हल कर सकता हूं?

ng v

Angular CLI: 9.1.0
Node: 13.9.0
OS: win32 x64

Angular: 9.1.0
... cli, core, forms, localize
Ivy Workspace: Yes

Package                             Version
-------------------------------------------------------------
@angular-devkit/architect           0.900.7
@angular-devkit/build-angular       0.900.7
@angular-devkit/build-optimizer     0.900.7
@angular-devkit/build-webpack       0.900.7
@angular-devkit/core                9.1.0
@angular-devkit/schematics          9.1.0
@angular/animations                 9.0.7
@angular/common                     9.0.7
@angular/compiler                   9.0.7
@angular/compiler-cli               9.0.7
@angular/language-service           9.0.7
@angular/platform-browser           9.0.7
@angular/platform-browser-dynamic   9.0.7
@angular/router                     9.0.7
@ngtools/webpack                    9.0.7
@schematics/angular                 9.1.0
@schematics/update                  0.901.0
rxjs                                6.5.4
typescript                          3.8.3
webpack                             4.41.2

मुझे @angular/core@9.1.0 की आवश्यकता है ताकि मैं ng serve के साथ टाइपस्क्रिप्ट 3.8.3 का उपयोग कर सकूं क्योंकि वर्तमान में मुझे इसके बिना इस तरह की त्रुटियां मिल रही हैं: error TS2314: Generic type 'ɵɵFactoryDef' requires 2 type argument(s).

मैंने --force विकल्प का उपयोग करके node_modules को हटाने और पुन: स्थापित करने का प्रयास किया है, संस्करण @angular/core@9.1.0 को निर्दिष्ट करते हुए, लेकिन कोई फायदा नहीं हुआ।

1
xinthose 30 मार्च 2020, 17:15

1 उत्तर

सबसे बढ़िया उत्तर

मैंने इस वेबसाइट, लेकिन @angular/core के लिए:

npm uninstall @angular/core
npm cache verify
npm install @angular/core@latest

ng update अब We analyzed your package.json and everything seems to be in order. Good work! दिखाता है

npm ls @angular/core ने मुझे यह दिखाया:

C:\Users\jsmith\AppData\Roaming\npm
`-- UNMET PEER DEPENDENCY @angular/core@9.1.0

npm ERR! peer dep missing: @angular/core@9.0.7, required by @angular/forms@9.0.7

इसलिए मैं package.json के सभी 9.0.7 को 9.1.0 से बदल देता हूं, फिर npm i और मेरी समस्याएं हल हो जाती हैं!

जब आप @angular/core को अपडेट करते हैं, तो ऐसा लगता है कि अन्य सभी @angular पैकेजों का एक ही संस्करण होना चाहिए, भले ही ^ का उपयोग किया जा रहा हो या नहीं।

4
xinthose 28 मई 2020, 15:39