मुझे पता है कि कोटलिन चलाते समय कोटलिन को जेडीके की आवश्यकता होती है। उदाहरण के लिए, मैं कोटलिन 1.4.0 का उपयोग करता हूं और मैं जेडीके 14 का उपयोग करता हूं। हालांकि, मैं कोटलिन और जेडीके संस्करण संगतता के बारे में निश्चित नहीं हूं।

क्या कोई कोटलिन और जेडीके संस्करण संगतता तालिका है?

मैंने आधिकारिक दस्तावेज़ को देखा लेकिन मुझे वह जानकारी नहीं मिली जो मैं चाहता था।

5
speed_star777 21 सितंबर 2020, 12:42

1 उत्तर

सबसे बढ़िया उत्तर

JVM के किन संस्करणों को कोटलिन लक्षित करता है?

कोटलिन आपको निष्पादन के लिए JVM का संस्करण चुनने देता है। डिफ़ॉल्ट रूप से, कोटलिन/जेवीएम कंपाइलर जावा 6 संगत बाइटकोड उत्पन्न करता है। यदि आप जावा के नए संस्करणों में उपलब्ध अनुकूलन का उपयोग करना चाहते हैं, तो आप स्पष्ट रूप से लक्ष्य जावा संस्करण को 8 से 13 तक निर्दिष्ट कर सकते हैं। ध्यान दें कि इस मामले में परिणामी बाइटकोड निचले संस्करणों पर नहीं चल सकता है।

https://kotlinlang.org/docs/reference/faq.html#who-versions-of-jvm-does-kotlin-target

6
Michael 21 सितंबर 2020, 12:47