क्या आप .NET Core 3.1 अनुप्रयोगों के साथ .NET Core 2.2 एप्लिकेशन चलाने में सक्षम हैं?

मुझे अस्पष्ट रूप से याद है कि .NET 3.1 इंस्टॉलर बहिष्कृत संस्करणों को हटा देता है (उदा. .NET 2.2)।

वेब सर्वर में कुछ अनुप्रयोग हैं जो .NET 2.2 हैं, और मुझे आशा है कि आप उन्हें एक-एक करके .NET 3.1 में अपग्रेड कर सकते हैं।

0
Kellen Stuart 8 अक्टूबर 2020, 17:53

1 उत्तर

सबसे बढ़िया उत्तर

हां।

आप साथ-साथ .NET कोर रनटाइम के एकाधिक संस्करण स्थापित कर सकते हैं। आपके आवेदन के मुख्य dll के आगे YOURAPP.runtimeconfig.json निर्धारित करता है कि किस संस्करण का उपयोग किया गया है।

आप Self-Conaned Deployments (SCD) का भी उपयोग कर सकते हैं आपके ऐप की रनटाइम निर्भरता को पूरी तरह से अलग करने के लिए, लेकिन 3.1 के लिए आपके आईआईएस में 3.1 आईआईएस मॉड्यूल स्थापित करने की आवश्यकता है।

2
Martin Ullrich 8 अक्टूबर 2020, 18:59