मैं अभी Node.js के लिए Actions SDK का उपयोग करके Google Assistant के लिए एक ऐप विकसित करना शुरू कर रहा हूँ; मैं पर्यावरण के लिए बिल्कुल नया हूं। मैं इस गाइड का पालन कर रहा हूं: https://developers.google.com/assistant/conversational/ त्वरित प्रारंभ

हालाँकि, मैं "गैक्शन कमांड-लाइन टूल स्थापित करें" के तहत चरण 4 पर अटक जाता हूं। गाइड सीएलआई को प्रमाणित करने के लिए "गैक्शन लॉगिन" कमांड का उपयोग करने के लिए कहता है, हालांकि जहां तक ​​​​मैं बता सकता हूं, "लॉगिन" गैक्शन सीएलआई के सबसे अद्यतित संस्करण के साथ एक वैध कमांड नहीं है। जब मैं उपलब्ध आदेशों के लिए gactions --help चलाता हूं तो मुझे यह मिलता है:

NAME:
   gactions - The Actions on Google command line interface that you can use to test and update your app for the Assistant.

USAGE:
   gactions.exe [global options] command [command options] [arguments...]

VERSION:
   2.2.4

COMMANDS:
   init        Create a default action.json file
   test        Takes the specified app for the Assistant and makes it available for previewing/simulation
   update      Updates the draft action in the app for the Assistant for the given project
   list        List up to 10 recent versions of your app for the Assistant: in review, production, approved, etc
   get         Get the contents of a given version of your app for the Assistant
   selfupdate  Checks for updates for this tool
   help, h     Shows a list of commands or help for one command

GLOBAL OPTIONS:
   --verbose, -v  Show more detailed output
   --help, -h     show help
   --version, -V  print the version

मेरे लिए gactions CLI के अपने संस्करण के साथ बहुत सीमित संख्या में कमांड उपलब्ध होने के कारण, ऐसा लगता है कि मुझे इसके साथ gactions CLI का उपयोग शुरू करने से पहले अपने ऐप को परिनियोजित करने की आवश्यकता है, जिसका मुझे कोई मतलब नहीं है। मैं एक खाली एक्शन प्रोजेक्ट क्यों तैनात करूंगा ताकि मैं इस पर गैक्शन के साथ काम करना शुरू कर सकूं?

Gactions CLI के लिए मुझे जो दस्तावेज़ मिले (https://developers.google.com/assistant/actionssdk/ gactions) समान रूप से पुराना लगता है। क्या किसी को पता है कि मुझे जीएक्शन सीएलआई के लिए अप-टू-डेट दस्तावेज़ कहां मिल सकते हैं?

1
druckgreen 8 पद 2020, 18:26

1 उत्तर

सबसे बढ़िया उत्तर

अगर आप क्विकस्टार्ट के Gactions इंस्टॉल करें सेक्शन को देखते हैं, तो आपको यह करना चाहिए नवीनतम बाइनरी, v3.1.0 के लिए उपयुक्त डाउनलोड ढूंढें। gactions v3+ के संदर्भ पृष्ठ में इसके बारे में अधिक जानकारी है।

0
Nick Felker 8 पद 2020, 18:12