मेरे index.js में मैंने शामिल किया है

const WooCommerceRestApi = require('@woocommerce/woocommerce-rest-api').default;

और package.json . में

"dependencies": {
"firebase-admin": "^9.2.0",
"firebase-functions": "^3.11.0",
"@woocommerce/woocommerce-rest-api": "^1.0.1"},

firebase deploy --only functions करते समय मुझे निम्न त्रुटि संदेश मिलता है:

npm ERR! Missing: @woocommerce/woocommerce-rest-api@^1.0.1

वही निर्भरता (स्थानीय रूप से स्थापित भी) स्थानीय वातावरण में ठीक काम कर रही है लेकिन इसे फायरबेस क्लाउड फ़ंक्शंस में तैनात करने में असमर्थ है।

समस्या क्या हो सकती है?

0
Caterpillaraoz 13 जिंदा 2021, 16:07

1 उत्तर

सबसे बढ़िया उत्तर

फिक्स्ड चेंजिंग

woocommerce/woocommerce-rest-api": "^1.0.1" package.json में

साथ

woocommerce/woocommerce-rest-api": ""

अभी भी यह पता लगाने के लिए कि यह किस पैकेज संस्करण का उपयोग करने का निर्णय लेता है: - /

1
Caterpillaraoz 17 जिंदा 2021, 03:06