आज (२०२०/१०/२७) मैं अपने डार्ट को संस्करण 2.10.2 में अपग्रेड करना चाहता हूं, फिर मैं इस कमांड का उपयोग करता हूं:

~ ⌚ 9:58:16
$ brew upgrade dart
Warning: dart-lang/dart/dart 2.9.3 already installed

2.10.2 में अपग्रेड क्यों नहीं किया जा सका? क्या मुझे स्रोतों से डार्ट स्थापित करना चाहिए?

0
Dolphin 27 अक्टूबर 2020, 05:05

1 उत्तर

सबसे बढ़िया उत्तर

brew upgrade के साथ अपग्रेड करने से पहले आपको brew update पहले कमांड चलाना होगा। upgrade कमांड क्या करता है पैकेज की सूची, उनके संस्करण, और कहां से डाउनलोड करना है। दूसरे शब्दों में, यह आपके द्वारा टैप किए गए प्रत्येक टैप और कोर टैप के लिए git pull चलता है। यह लिनक्स सिस्टम पर उपयुक्त sudo apt-get update के समान है। संक्षेप में, बस brew update && brew upgrade dart चलाएं और इसे काम करना चाहिए। यदि यह कुछ लोगों के लिए काम नहीं करता है, तो हो सकता है कि आपको इस संस्करण को प्राप्त करने के लिए स्रोत से इंस्टॉल करना पड़े, जैसा कि प्रश्न में बताया गया है।

1
Nathan Chu 27 अक्टूबर 2020, 12:16