जब मैं npx install-peerdeps --dev eslint-config-airbnb के साथ eslint-config-airbnb स्थापित करने का प्रयास कर रहा हूं तो मुझे निम्न त्रुटि मिल रही है (--legacy-peer-deps ध्वज मदद नहीं करता है):

npm ERR! ERESOLVE unable to resolve dependency tree
npm ERR! 
npm ERR! While resolving: favnote@0.1.0
npm ERR! Found: eslint@7.2.0
npm ERR! node_modules/eslint
npm ERR!   dev eslint@"7.2.0" from the root project
npm ERR!   peer eslint@"^5.16.0 || ^6.8.0 || ^7.2.0" from eslint-config-airbnb@18.2.1
npm ERR!   node_modules/eslint-config-airbnb
npm ERR!     dev eslint-config-airbnb@"18.2.1" from the root project
npm ERR!   3 more (eslint-plugin-import, eslint-plugin-jsx-a11y, eslint-plugin-react)
npm ERR! 
npm ERR! Could not resolve dependency:
npm ERR! peer eslint@"^3.0.0 || ^4.0.0 || ^5.0.0 || ^6.0.0" from eslint-plugin-react-hooks@4.0.0    
npm ERR! node_modules/eslint-plugin-react-hooks
npm ERR!   dev eslint-plugin-react-hooks@"4.0.0" from the root project
npm ERR!   peer eslint-plugin-react-hooks@"^4 || ^3 || ^2.3.0 || ^1.7.0" from eslint-config-airbnb@18.2.1
npm ERR!   node_modules/eslint-config-airbnb
npm ERR!     dev eslint-config-airbnb@"18.2.1" from the root project
npm ERR! 
npm ERR! Fix the upstream dependency conflict, or retry
npm ERR! this command with --force, or --legacy-peer-deps
npm ERR! to accept an incorrect (and potentially broken) dependency resolution.
npm ERR! ```
1
Paweł 17 नवम्बर 2020, 14:51

1 उत्तर

सबसे बढ़िया उत्तर

npm install --legacy-peer-deps चलाएं और वे सफलतापूर्वक इंस्टॉल हो जाएंगे।

अपने package.json को देखते हुए और इसकी तुलना eslint-config-airbnb के लिए सूचीबद्ध सहकर्मी निर्भरता से करते हैं, आपके पास पहले से ही आपके package.json में देव निर्भरता के रूप में सभी सहकर्मी निर्भरताएँ हैं। (वे संभवतः वहां जोड़े गए थे जब आपने npx install-peerdeps कमांड चलाया था लेकिन फिर उस कमांड ने npm install को चलाने की कोशिश की और असफल रहे।)

2
Trott 18 नवम्बर 2020, 13:16