Npm में webpack-dev-server चलाते समय मुझे यह त्रुटि मिल रही है:

webpack-dev-middleware@3.7.2 requires a peer of webpack@^4.0.0 but none is installed. You must install peer dependencies yourself.

हालाँकि, मैंने पहले ही वेबपैक स्थापित कर लिया है। यहाँ मेरा package.json है। मैं क्या खो रहा हूँ?

{
  ...
  "scripts": {
    "watch": "webpack-dev-server --progress --https"
  },
  ...
  "devDependencies": {
    "webpack": "^5.4.0",
    "webpack-cli": "^4.2.0",
    "webpack-dev-server": "^3.11.0"
  }
}
1
Zack 8 नवम्बर 2020, 01:49

1 उत्तर

सबसे बढ़िया उत्तर

आपके पास webpack@5 स्थापित है लेकिन सहकर्मी निर्भरता चेतावनी webpack@4 मांग रही है। webpack-dev-server इश्यू ट्रैकर में एक बग फाइल किया गया है वेबपैक@5 के साथ असंगति के बारे में। कुछ दिनों पहले तक, वे इस पर काम कर रहे हैं।

तो एक विकल्प यह है कि धैर्य रखें और उस मुद्दे को देखें। जब कोई संस्करण संगत webpack@5 जारी किया जाता है, तो उसमें अपग्रेड करें।

एक अन्य विकल्प यह है कि आप अपने वर्तमान प्रोजेक्ट को वेबपैक@4 पर डाउनग्रेड करें। मुझे नहीं पता कि वेबपैक@4 और वेबपैक@5 के बीच ब्रेकिंग परिवर्तन कितने बड़े हैं, लेकिन यह कोशिश करने का एक विकल्प है। यह देखते हुए कि webpack@5.0.0 केवल एक महीने पहले जारी किया गया था, यह एक ठीक विकल्प हो सकता है। webpack@4.x का नवीनतम संस्करण webpack@4.44.2 है और (इस लेखन के समय) केवल 2 महीने पुराना है।

2
Trott 8 नवम्बर 2020, 00:01