मैं cmd ​​​​में कमांड का उपयोग कर रहा हूं: py -3.7.6 -m googlesamples.assistant.grpc.audio_helpers

यह काम नहीं करता। मुझे एक प्रतिक्रिया मिलती है:

Unknown option: -3
usage: C:\Users\Yakuza\AppData\Local\Programs\Python\Python39\python.exe [option] ... [-c cmd | -m mod | file | -] [arg] ...
Try `python -h' for more information.

===========================

इसके काम करने के लिए संस्करण कैसे निर्दिष्ट करें?

मूर्खतापूर्ण प्रश्न के लिए क्षमा करें, मैं अभी थक गया हूँ, लेकिन मैं समाप्त करना चाहता हूँ

0
romanefimen 24 जिंदा 2021, 16:51
stackoverflow.com/a/13211456/5267751 के अनुसार इसे उस बग फिक्स संस्करण के बिना काम करना चाहिए।
 – 
user202729
24 जिंदा 2021, 16:55

1 उत्तर

सबसे बढ़िया उत्तर

आप Windows के लिए Python Launcher का उपयोग करके 3.7.6 निर्दिष्ट नहीं कर सकते, यह केवल पहले दो अंकों, major.minor को पहचानता है। आप फ़ाइल में एक शेबैंग लाइन का उपयोग कर सकते हैं। पथ। या अपने इच्छित संस्करण का पथ निर्दिष्ट करें - C:\path\to\pythonV3.7.6\python.exe -m ...

0
wwii 24 जिंदा 2021, 17:47
मैंने पहले ही पता लगा लिया है कि "py -3.7" का सही तरीके से उपयोग कैसे करें। पहले अजगर के "3.7" संस्करण को स्वयं xD स्थापित करना आवश्यक था। लेकिन फिर भी उत्तर के लिए बहुत धन्यवाद :3
 – 
romanefimen
24 जिंदा 2021, 17:51