मैं सिम्फनी में काफी नया हूं और अपने इंटर्नशिप के लिए इस मुद्दे के साथ संघर्ष करता हूं, जब स्थानीय रूप से परियोजना को चलाने की कोशिश कर रहा हूं:

(1/1) InvalidConfigurationException        
 In ArrayNode.php line 331:                                                                                                                                                                                                                                     
      Unrecognized option "mailer" under "framework". Available options are "annotations", "assets", "cache", [...], "workflows".

मैं PHP 7.4 और सिम्फनी 4 चला रहा हूं, किसी अन्य देव से सिम्फनी प्रोजेक्ट को अपनाना।

मेरी .env फ़ाइल में, मुझे स्विफ्टमेलर बंडल मिला, मेरा मानना ​​है कि मेलर एक अलग तरह का मेलर बंडल इस्तेमाल किया गया था ..?

मैंने निम्नलिखित अनुरोध की कोशिश की:

 composer require symfony/mailer

और यह मिला:

    The "symfony/flex" plugin was skipped because it is not compatible with Composer 2+. Make sure to update it to version 1.9.8 or greater.
Using version ^5.2 for symfony/mailer
./composer.json has been updated
The "symfony/flex" plugin was skipped because it is not compatible with Composer 2+. Make sure to update it to version 1.9.8 or greater.
Running composer update symfony/mailer
Loading composer repositories with package information
Updating dependencies
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - symfony/mailer[v5.2.0, ..., v5.2.2] require symfony/event-dispatcher ^4.4|^5.0 -> found symfony/event-dispatcher[v4.4.0, ..., v4.4.19, v5.0.0, ..., v5.2.2] but the package is fixed to v4.2.8 (lock file version) by a partial up
date and that version does not match. Make sure you list it as an argument for the update command.
    - Root composer.json requires symfony/mailer ^5.2 -> satisfiable by symfony/mailer[v5.2.0, v5.2.1, v5.2.2].

Use the option --with-all-dependencies (-W) to allow upgrades, downgrades and removals for packages currently locked to specific versions.

Installation failed, reverting ./composer.json and ./composer.lock to their original content.

आपकी सहायताके लिए धन्यवाद !

0
Jerome59 29 जिंदा 2021, 12:17

1 उत्तर

सबसे बढ़िया उत्तर

यदि आप किसी अन्य देव के प्रोजेक्ट को किकस्टार्ट कर रहे हैं, तो संभवतः आपको किसी composer require की आवश्यकता नहीं है। पिछले डेवलपर के समान सभी पैकेज प्राप्त करने के लिए आपको केवल composer install को प्रोजेक्ट डायरेक्टरी में चलाना है।

0
nikserg 29 जिंदा 2021, 12:33
मैंने कंपोज़र इंस्टाल चलाने की कोशिश की लेकिन यह असफल रहा। मुझे तब कंपोज़र अपडेट चलाने की सलाह दी गई थी और यह भी विफल रहा (packagist.org (HHTP/2 504) से कुछ फ़ाइलें डाउनलोड नहीं कर सका
 – 
Jerome59
29 जिंदा 2021, 12:51
क्या आप कमांड का आउटपुट प्रदान कर सकते हैं?
 – 
nikserg
29 जिंदा 2021, 12:54
कंपोज़र इंस्टाल का परिणाम: codeshare.io/G8RBzE
 – 
Jerome59
29 जिंदा 2021, 13:17
क्या आपने composer update चलाने की कोशिश की है, जैसा कि यह लॉग बताता है?
 – 
nikserg
29 जिंदा 2021, 13:31
HI, हाँ मैंने कोशिश की और मुझे त्रुटियों का भी सामना करना पड़ा। मैंने एक स्वच्छ परियोजना से फिर से शुरू किया और जैसा कि आपने सुझाव दिया है, संगीतकार स्थापित करने के लिए विक्रेताओं को धन्यवाद दिया, और अंत में यह काम कर गया! जैसा कि मैं पहली बार उस तरह से आगे नहीं बढ़ा।
 – 
Jerome59
1 फरवरी 2021, 15:55